sqoop-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Abraham Fine <...@abrahamfine.com>
Subject Re: Review Request 47674: Sqoop2: Support using password generators for repository passwords
Date Tue, 24 May 2016 20:24:26 GMT

-----------------------------------------------------------
This is an automatically generated e-mail. To reply, visit:
https://reviews.apache.org/r/47674/#review134627
-----------------------------------------------------------



really appreciate all of the additional tests, 2 more small comments and then the code should
be ready to commit.


core/src/test/java/org/apache/sqoop/repository/TestJdbcRepositoryContextInitialization.java
(line 41)
<https://reviews.apache.org/r/47674/#comment199465>

    this can likely be put in a "before" method so it does not need to be repeated.



core/src/test/java/org/apache/sqoop/repository/TestJdbcRepositoryContextInitialization.java
(line 49)
<https://reviews.apache.org/r/47674/#comment199466>

    nit-pick: test names are a little long, could rename to "testInvalidJdbcHandlerClassName"


- Abraham Fine


On May 24, 2016, 8:16 p.m., Szabolcs Vasas wrote:
> 
> -----------------------------------------------------------
> This is an automatically generated e-mail. To reply, visit:
> https://reviews.apache.org/r/47674/
> -----------------------------------------------------------
> 
> (Updated May 24, 2016, 8:16 p.m.)
> 
> 
> Review request for Sqoop.
> 
> 
> Bugs: SQOOP-2914
>     https://issues.apache.org/jira/browse/SQOOP-2914
> 
> 
> Repository: sqoop-sqoop2
> 
> 
> Description
> -------
> 
> Sqoop2: Support using password generators for repository passwords
> 
> 
> Diffs
> -----
> 
>   core/src/main/java/org/apache/sqoop/repository/JdbcRepositoryContext.java 0a8139a 
>   core/src/main/java/org/apache/sqoop/repository/RepoConfigurationConstants.java 12cb93e

>   core/src/test/java/org/apache/sqoop/repository/TestJdbcRepositoryContextInitialization.java
PRE-CREATION 
> 
> Diff: https://reviews.apache.org/r/47674/diff/
> 
> 
> Testing
> -------
> 
> 
> Thanks,
> 
> Szabolcs Vasas
> 
>


Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message