sqoop-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Attila Szabo (JIRA)" <j...@apache.org>
Subject [jira] [Updated] (SQOOP-3190) Remove dependency on PSQL for postgres direct import
Date Mon, 30 Oct 2017 13:59:00 GMT

     [ https://issues.apache.org/jira/browse/SQOOP-3190?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Attila Szabo updated SQOOP-3190:
--------------------------------
    Fix Version/s:     (was: 1.4.7)
                   1.5.0

> Remove dependency on PSQL for postgres direct import
> ----------------------------------------------------
>
>                 Key: SQOOP-3190
>                 URL: https://issues.apache.org/jira/browse/SQOOP-3190
>             Project: Sqoop
>          Issue Type: Improvement
>          Components: connectors/postgresql
>    Affects Versions: 1.4.7
>            Reporter: Alex Ang Hock Hee
>            Priority: Minor
>              Labels: newbie
>             Fix For: 1.5.0
>
>         Attachments: DirectPostgresqlManager.patch, DirectPostgresqlManager_v2.patch
>
>   Original Estimate: 24h
>  Remaining Estimate: 24h
>
> Current Postgres direct import requires the installation of the psql utility on all hadoop
nodes. However, due to system constraints, this may not always be possible. 
> It should be noted that Postgres provides a Java API which can execute the same copy
command as the psql utility. As such, it would be more ideal to remove the psql utility dependency
and switch to the Postgres Java API.



--
This message was sent by Atlassian JIRA
(v6.4.14#64029)

Mime
View raw message