sqoop-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Hudson (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (SQOOP-3346) Upgrade Hadoop version to 2.8.0
Date Fri, 20 Jul 2018 09:24:00 GMT

    [ https://issues.apache.org/jira/browse/SQOOP-3346?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16550554#comment-16550554
] 

Hudson commented on SQOOP-3346:
-------------------------------

SUCCESS: Integrated in Jenkins build Sqoop-hadoop200 #1184 (See [https://builds.apache.org/job/Sqoop-hadoop200/1184/])
SQOOP-3346: Upgrade Hadoop version to 2.8.0 (vasas: [https://git-wip-us.apache.org/repos/asf?p=sqoop.git&a=commit&h=b3e941be050d615f6aae5b4fafb9e0754c8c6a72])
* (edit) src/java/org/apache/sqoop/tool/ImportTool.java
* (edit) src/test/org/apache/sqoop/manager/sqlserver/SQLServerParseMethodsTest.java
* (edit) src/java/org/apache/sqoop/mapreduce/JobBase.java
* (edit) src/test/org/apache/sqoop/orm/TestParseMethods.java
* (edit) src/java/org/apache/sqoop/config/ConfigurationConstants.java
* (edit) src/java/org/apache/sqoop/config/ConfigurationHelper.java
* (edit) src/test/org/apache/sqoop/TestSqoopOptions.java
* (edit) ivy/libraries.properties


> Upgrade Hadoop version to 2.8.0
> -------------------------------
>
>                 Key: SQOOP-3346
>                 URL: https://issues.apache.org/jira/browse/SQOOP-3346
>             Project: Sqoop
>          Issue Type: Sub-task
>            Reporter: Boglarka Egyed
>            Assignee: Boglarka Egyed
>            Priority: Major
>             Fix For: 3.0.0
>
>         Attachments: SQOOP-3346.patch
>
>
> Support for AWS temporary credentials has been introduced in Hadoop 2.8.0 based on HADOOP-12537 and
it would make more sense to test and support this capability too with Sqoop.
> There is [SQOOP-3305|https://reviews.apache.org/r/66300/bugs/SQOOP-3305/] being open
for upgrading Hadoop to 3.0.0 however it has several issues described in [https://reviews.apache.org/r/66300/] currently thus
I would like to proceed with an "intermediate" upgrade to 2.8.0 to enable development on S3
front. [~dvoros] are you OK with this?



--
This message was sent by Atlassian JIRA
(v7.6.3#76005)

Mime
View raw message