sqoop-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Boglarka Egyed (JIRA)" <j...@apache.org>
Subject [jira] [Updated] (SQOOP-3352) Bump java target version to 1.8
Date Wed, 25 Jul 2018 09:49:00 GMT

     [ https://issues.apache.org/jira/browse/SQOOP-3352?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Boglarka Egyed updated SQOOP-3352:
----------------------------------
    Attachment: SQOOP-3352.patch

> Bump java target version to 1.8
> -------------------------------
>
>                 Key: SQOOP-3352
>                 URL: https://issues.apache.org/jira/browse/SQOOP-3352
>             Project: Sqoop
>          Issue Type: Improvement
>    Affects Versions: 1.4.7
>            Reporter: Boglarka Egyed
>            Assignee: Boglarka Egyed
>            Priority: Major
>             Fix For: 3.0.0
>
>         Attachments: SQOOP-3352.patch, SQOOP-3352.patch, SQOOP-3352.patch
>
>
> We should move to Java 8 as a minimum requirement.
> Java 7 is EOL'ed for more than 3 years now: [http://www.oracle.com/technetwork/java/eol-135779.html]
> Many Apache projects are adopting Java 8 as a minimum requirement, for instance:
>  * Hadoop 3: HADOOP-11858
>  * Hbase 2: HBASE-15624
>  * Flume 1.8: FLUME-2945
> This change affects the Ant and the Gradle build too.
>  



--
This message was sent by Atlassian JIRA
(v7.6.3#76005)

Mime
View raw message