sqoop-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Szabolcs Vasas (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (SQOOP-3232) Remove Sqoop dependency on deprecated HBase APIs
Date Wed, 24 Oct 2018 15:15:00 GMT

    [ https://issues.apache.org/jira/browse/SQOOP-3232?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16662406#comment-16662406
] 

Szabolcs Vasas commented on SQOOP-3232:
---------------------------------------

Hi [~szewinho],

Yes, this improvement will be included in the next Sqoop release, I am not sure about the
version number yet, it is going to be 1.5.0 or 3.0.0.

We are still working on some non-trivial library upgrades (https://issues.apache.org/jira/browse/SQOOP-3305) most
probably we will have to wait for an HBase release that supports Hadoop 3.x properly and
the community has to find the time for preparing the release so there is no ETA yet.

 

> Remove Sqoop dependency on deprecated HBase APIs
> ------------------------------------------------
>
>                 Key: SQOOP-3232
>                 URL: https://issues.apache.org/jira/browse/SQOOP-3232
>             Project: Sqoop
>          Issue Type: Improvement
>    Affects Versions: 1.4.6
>            Reporter: Szabolcs Vasas
>            Assignee: Szabolcs Vasas
>            Priority: Major
>             Fix For: 1.5.0
>
>         Attachments: SQOOP-3232-2.patch, SQOOP-3232.patch
>
>
> Sqoop currently depends on pre HBase 1.0 APIs that have been deprecated and will be removed
in the HBase 2.0 release.
> The task is to remove the dependency on these old APIs to make sure that the upgrade
to a newer HBase version will be easier in the future.



--
This message was sent by Atlassian JIRA
(v7.6.3#76005)

Mime
View raw message