sqoop-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Fero Szabo (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (SQOOP-3381) Upgrade the Parquet library from 1.6.0 to 1.9.0
Date Mon, 15 Oct 2018 14:45:00 GMT

    [ https://issues.apache.org/jira/browse/SQOOP-3381?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16650311#comment-16650311
] 

Fero Szabo commented on SQOOP-3381:
-----------------------------------

Hi [~dvoros],

Thanks for letting me know.

Anyway, I've just updated my patch on Reviewboard. I encountered the same security policy
related issue as you did with the Hadoop upgrade in SQOOP-3305, so I've incorporated the
DerbyPolicy and the related code changes in mine. I hope you approve, and can have a look
at it. :)

I've decided to go for an older version of Hive, 2.1.1, since that suffices for this parquet
upgrade as well.

 

> Upgrade the Parquet library from 1.6.0 to 1.9.0
> -----------------------------------------------
>
>                 Key: SQOOP-3381
>                 URL: https://issues.apache.org/jira/browse/SQOOP-3381
>             Project: Sqoop
>          Issue Type: Sub-task
>    Affects Versions: 1.4.7
>            Reporter: Fero Szabo
>            Assignee: Fero Szabo
>            Priority: Major
>             Fix For: 3.0.0
>
>
> As we will need to register a data supplier in the fix for parquet decimal support, we
will need a version that contains PARQUET-243.
> We need to upgrade the Parquet library to a version that contains this fix and is compatible
with Hadoop. Most probably, the newest version will be adequate. 



--
This message was sent by Atlassian JIRA
(v7.6.3#76005)

Mime
View raw message