sqoop-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Daniel Voros (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (SQOOP-3381) Upgrade the Parquet library from 1.6.0 to 1.9.0
Date Fri, 05 Oct 2018 11:00:03 GMT

    [ https://issues.apache.org/jira/browse/SQOOP-3381?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16639659#comment-16639659
] 

Daniel Voros commented on SQOOP-3381:
-------------------------------------

With SQOOP-3305 I've decided to hold off until there's an HBase release that supports Hadoop
3.x. I don't think Hive 3.1.0 would help in this regard, since parquet classes are still shaded
in hive-exec:3.1.0.

> Upgrade the Parquet library from 1.6.0 to 1.9.0
> -----------------------------------------------
>
>                 Key: SQOOP-3381
>                 URL: https://issues.apache.org/jira/browse/SQOOP-3381
>             Project: Sqoop
>          Issue Type: Sub-task
>    Affects Versions: 1.4.7
>            Reporter: Fero Szabo
>            Assignee: Fero Szabo
>            Priority: Major
>             Fix For: 3.0.0
>
>
> As we will need to register a data supplier in the fix for parquet decimal support, we
will need a version that contains PARQUET-243.
> We need to upgrade the Parquet library to a version that contains this fix and is compatible
with Hadoop. Most probably, the newest version will be adequate. 



--
This message was sent by Atlassian JIRA
(v7.6.3#76005)

Mime
View raw message