sqoop-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "ASF subversion and git services (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (SQOOP-3104) Create test categories instead of test suites and naming conventions
Date Wed, 14 Nov 2018 15:42:00 GMT

    [ https://issues.apache.org/jira/browse/SQOOP-3104?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16686725#comment-16686725
] 

ASF subversion and git services commented on SQOOP-3104:
--------------------------------------------------------

Commit d58e5f106ba932879112d7b69997301e442335f1 in sqoop's branch refs/heads/trunk from [~vasas]
[ https://git-wip-us.apache.org/repos/asf?p=sqoop.git;h=d58e5f1 ]

SQOOP-3104: Create test categories instead of test suites and naming conventions

(Nguyen Truong via Szabolcs Vasas)


> Create test categories instead of test suites and naming conventions
> --------------------------------------------------------------------
>
>                 Key: SQOOP-3104
>                 URL: https://issues.apache.org/jira/browse/SQOOP-3104
>             Project: Sqoop
>          Issue Type: Sub-task
>            Reporter: Anna Szonyi
>            Assignee: Nguyen Truong
>            Priority: Major
>
> We are currently unsing test naming conventions to differentiate between ManualTests,
Unit tests and 3rd party tests.
> Instead of this, we should use junit4 categories, so it's clear by looking at a test
where it fits. This would also remove the reliance on the test class name.



--
This message was sent by Atlassian JIRA
(v7.6.3#76005)

Mime
View raw message