sqoop-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "arvind@cloudera.com" <arv...@cloudera.com>
Subject Re: [sqoop-user] Re: regarding errors in build sqoop
Date Sat, 06 Aug 2011 00:36:43 GMT
[bcc: sqoop-user@cloudera.org, to:sqoop-user@incubator.apache.org.
Please move the discussion to Apache mailing list]

Sonal,

If you cannot ping the central maven repo (repo1.maven.org), it is
likely that your network connection is not configured correctly, or
worse black listed for access via Apache infrastructure. I would
suggest that you file an INFRA jira to help get that resolved.

Thanks,
Arvind


PS -> Please subscribe to sqoop-user@incubator.apache.org and continue
this thread there for faster response.

On Tue, Aug 2, 2011 at 9:52 PM, Sonal <imsonalkumar@gmail.com> wrote:
> Hi,
>
> Even in the link you provided:
> == The Basics
>
> Sqoop is compiled with ant. Type +ant -p+ to see the list of available
> targets.
>
> Type +ant+ to compile all java sources. You can then run Sqoop with
> +bin/sqoop+.
>
> If you want to build everything (including the documentation), type
> +ant package+. This will appear in the
> +build/sqoop-(version)/+ directory.
>
> Sqoop is built against the latest Hadoop distribution available from
> Cloudera.
> These dependencies are obtained via IVY which downloads the necessary
> binaries
> from Cloudera maven repository.
>
> These are the steps.
>
> Is there any other repository available from where i can fix the
> dependencies.
>
> Quick reply will be helpful.
>
> On Aug 3, 3:29 am, "arv...@cloudera.com" <arv...@cloudera.com> wrote:
>> [bcc: sqoop-u...@cloudera.org, to:sqoop-u...@incubator.apache.org.
>> Please move the discussion to Apache mailing list]
>>
>> Hi Sonal,
>>
>> The code for Sqoop has been migrated to Apache Incubator and you can
>> check it out from the following Subversion URL:
>>
>> https://svn.apache.org/repos/asf/incubator/sqoop/trunk/
>>
>> Please checkout the latest code from there and see if that builds
>> properly for you. I would suggest that you get rid of the .ivy2
>> directory from your home dir in order to force the refresh of all your
>> dependencies.
>>
>> Thanks,
>> Arvind
>>
>>
>>
>>
>>
>> On Tue, Aug 2, 2011 at 7:32 AM, Sonal <imsonalku...@gmail.com> wrote:
>> > Hi,
>>
>> > I have downloaded the sqoop-1.3.0 from :https://github.com/cloudera/sqoop
>> > I did ant and it failed at target ivy-resolve-hadoop
>> > I have a
>> > ant version : 1.7.1
>> > hadoop version: hadoop-0.20.203.0
>> > hbase version: hbase-0.90.3
>>
>> > [ivy:resolve]
>> > [ivy:resolve] :: problems summary ::
>> > [ivy:resolve] :::: WARNINGS
>> > [ivy:resolve]           module not found: commons-cli#commons-cli;1.2
>> > [ivy:resolve]   ==== apache-snapshot: tried
>> > [ivy:resolve]
>> >https://repository.apache.org/content/repositories/snapshots/commons-...
>> > [ivy:resolve]     -- artifact commons-cli#commons-cli;1.2!commons-
>> > cli.jar:
>> > [ivy:resolve]
>> >https://repository.apache.org/content/repositories/snapshots/commons-...
>> > [ivy:resolve]   ==== cloudera-releases: tried
>> > [ivy:resolve]
>> >https://repository.cloudera.com/content/repositories/releases/commons...
>> > [ivy:resolve]     -- artifact commons-cli#commons-cli;1.2!commons-
>> > cli.jar:
>> > [ivy:resolve]
>> >https://repository.cloudera.com/content/repositories/releases/commons...
>> > [ivy:resolve]   ==== cloudera-staging: tried
>> > [ivy:resolve]
>> >https://repository.cloudera.com/content/repositories/staging/commons-...
>> > [ivy:resolve]     -- artifact commons-cli#commons-cli;1.2!commons-
>> > cli.jar:
>> > [ivy:resolve]
>> >https://repository.cloudera.com/content/repositories/staging/commons-...
>> > [ivy:resolve]   ==== maven2: tried
>> > [ivy:resolve]    http://repo1.maven.org/maven2/commons-cli/commons-cli/1.2/commons-cli...
>> > [ivy:resolve]     -- artifact commons-cli#commons-cli;1.2!commons-
>> > cli.jar:
>> > [ivy:resolve]    http://repo1.maven.org/maven2/commons-cli/commons-cli/1.2/commons-cli...
>> > [ivy:resolve]           module not found: commons-logging#commons-
>> > logging;1.0.4
>> > [ivy:resolve]           ::::::::::::::::::::::::::::::::::::::::::::::
>> > [ivy:resolve]           ::          UNRESOLVED DEPENDENCIES    
    ::
>> > [ivy:resolve]           ::::::::::::::::::::::::::::::::::::::::::::::
>> > [ivy:resolve]           :: commons-cli#commons-cli;1.2: not found
>> > [ivy:resolve]           :: commons-logging#commons-logging;1.0.4: not
>> > found
>> > [ivy:resolve]           :: log4j#log4j;1.2.15: not found
>> > [ivy:resolve]           :: hsqldb#hsqldb;1.8.0.10: not found
>> > [ivy:resolve]           :: commons-io#commons-io;1.4: not found
>> > [ivy:resolve]           :: com.cloudera.hadoop#hadoop-core;0.20.2-737:
>> > not found
>> > [ivy:resolve]           :: org.apache.hbase#hbase;0.89.20100924-28:
>> > not found
>> > [ivy:resolve]           ::::::::::::::::::::::::::::::::::::::::::::::
>> > [ivy:resolve] :::: ERRORS
>> > [ivy:resolve]   Server access Error: No route to host url=https://
>> > repository.apache.org/content/repositories/snapshots/commons-cli/
>> > commons-cli/1.2/commons-cli-1.2.pom
>> > [ivy:resolve]   Server access Error: No route to host url=https://
>> > repository.apache.org/content/repositories/snapshots/commons-cli/
>> > commons-cli/1.2/commons-cli-1.2.jar
>> > [ivy:resolve]   Server access Error: No route to host url=https://
>> > repository.cloudera.com/content/repositories/releases/commons-cli/
>> > commons-cli/1.2/commons-cli-1.2.pom
>> > [ivy:resolve]   Server access Error: No route to host url=https://
>> > repository.cloudera.com/content/repositories/releases/commons-cli/
>> > commons-cli/1.2/commons-cli-1.2.jar
>> > [ivy:resolve]   Server access Error: No route to host url=https://
>> > repository.cloudera.com/content/repositories/staging/commons-cli/
>> > commons-cli/1.2/commons-cli-1.2.pom
>> > [ivy:resolve]   Server access Error: No route to host url=https://
>> > repository.cloudera.com/content/repositories/staging/commons-cli/
>> > commons-cli/1.2/commons-cli-1.2.jar
>> > [ivy:resolve]   Server access Error: No route to host url=http://
>> > repo1.maven.org/maven2/commons-cli/commons-cli/1.2/commons-cli-1.2.pom
>> > [ivy:resolve]   Server access Error: No route to host url=http://
>> > repo1.maven.org/maven2/commons-cli/commons-cli/1.2/commons-cli-1.2.jar
>>
>> > Can you help in this?
>>
>> > Thanks & Regards,
>> > Sonal Kumar
>>
>> > --
>> > NOTE: The mailing list sqoop-u...@cloudera.org is deprecated in favor of Apache
Sqoop mailing list sqoop-u...@incubator.apache.org. Please subscribe to it by sending an email
to incubator-sqoop-user-subscr...@apache.org.
>
> --
> NOTE: The mailing list sqoop-user@cloudera.org is deprecated in favor of Apache Sqoop
mailing list sqoop-user@incubator.apache.org. Please subscribe to it by sending an email to
incubator-sqoop-user-subscribe@apache.org.
>

Mime
View raw message