sqoop-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Eric Wadsworth <e...@wadhome.org>
Subject Re: Problem in using sqoop with oracle
Date Thu, 15 Dec 2011 17:41:02 GMT
What version of hadoop and hbase is your cluster?

I'm getting the same error, on my own build of sqoop, built against 
hadoop version 0.20 and running against apache hadoop version 0.20), 
whenever I try to use it with oracle. I dug into the code, but didn't 
find anything obviously wrong in there.

--- wad

On 12/14/2011 09:47 PM, Mohammad Tariq wrote:
> Hello list,
>
>       I am trying to store the tables from an oracle database on a
> remote machine and store it in the Hbase. But I am getting the below
> specified error -
>
> solr@ubuntu:~$ sqoop import --connect
> jdbc:oracle:thin:@//BLR-WS-202.pointcrossblr.com/ORCHDB --table
> R_SOURCE --username ppdmdb --password ppdmdb --hbase-create-table
> --hbase-table WIT --column-family myfamily
> 11/12/15 11:13:04 WARN tool.BaseSqoopTool: Setting your password on
> the command-line is insecure. Consider using -P instead.
> 11/12/15 11:13:04 INFO manager.SqlManager: Using default fetchSize of 1000
> 11/12/15 11:13:04 INFO tool.CodeGenTool: Beginning code generation
> 11/12/15 11:13:04 INFO manager.OracleManager: Time zone has been set to GMT
> 11/12/15 11:13:04 INFO manager.SqlManager: Executing SQL statement:
> SELECT t.* FROM R_SOURCE t WHERE 1=0
> 11/12/15 11:13:05 ERROR tool.ImportTool: Imported Failed: Attempted to
> generate class with no columns!
>
> Need some help.Thank you
>
> Regards,
>      Mohammad Tariq


Mime
View raw message