sqoop-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From David Robson <David.Rob...@quest.com>
Subject RE: [sqoop-user] Sqoop export - Date issue with Oracle
Date Tue, 17 Jan 2012 23:22:39 GMT
Hi Nago,

I just tried this out with a file the same as you specified and got the same error as you.

The good news is when I used the Quest Data Connector for Oracle and Hadoop it worked fine
- so perhaps you could use that instead?

You can download it from here: http://toadforcloud.com/entry.jspa?categoryID=677&externalID=4298
Source code is available here under Apache 2.0 license: https://github.com/QuestSoftwareTCD/OracleSQOOPconnector

Let us know if this resolves your issue.



-----Original Message-----
From: nago [mailto:ngopal85@gmail.com] 
Sent: Wednesday, 18 January 2012 3:16 AM
To: Sqoop Users
Subject: [sqoop-user] Sqoop export - Date issue with Oracle

Hello Friends,

I am trying to do sqooping the data from HDFC file to Oracle (10.2g) table.
I could do sqooping if no date value in the file.

But, if i have date value in the file , it throws exception that "Timestamp format must be
yyyy-mm-dd hh:mm:ss[.fffffffff] ".
what is the problem ?What should i do , so that i can avoid this issue ?

This the sqoop command i have :
 sqoop export  --connect jdbc:oracle:thin:@// --
username NAGO  -P  --table WD1   --export-dir /services/location/
mapskpi/reporting/data/test/ --fields-terminated-by ,

data in the file will look alike:

Oracle Table WD1:
FI_DT        DATE
YR        NUMBER(38)
CNT1      NUMBER(38)
CNT2      NUMBER(38)
CNT3      NUMBER(38)

can you please help ?


NOTE: The mailing list sqoop-user@cloudera.org is deprecated in favor of Apache Sqoop mailing
list sqoop-user@incubator.apache.org. Please subscribe to it by sending an email to incubator-sqoop-user-subscribe@apache.org.

View raw message