sqoop-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jarek Jarcec Cecho <jar...@apache.org>
Subject Re: import error: column name '........pg.dropped.16........' not in table
Date Sat, 25 Feb 2012 06:11:39 GMT
Hi Johnny,
would you mind running sqoop again with parameter --verbose and sending entire output?

Jarcec

On Fri, Feb 24, 2012 at 10:57:26AM -0500, Tolliver, Johnny S. wrote:
> Hello all,
> 
> I'm new to sqoop. I'm using CDH3U2 and testing sqoop against a GreenPlum database. I've
successfully imported two smallish tables into Hive without problems, but on a third table,
which is only slightly more complicated, I'm getting the error
> 
> column name '........pg.dropped.16........' not in table
> 
> I've tried with both the postgresql driver version 8.4-703 and 9.1-901 and get the same
errors.
> 
> I've also tried create-hive-table instead of import and get a different error. This time
a NullPointerException at com.cloudera.sqoop.hive.TableDefWriter.getCreateTableStat at line
151. Same results with both postgresql drivers.
> 
> The table I'm trying to import has 15 columns and is not complicated. Here is a create
table command used in GreenPlum with the names changed to protect the innocent.
> 
> CREATE TABLE XXX (
>         aaa varchar(2) NOT NULL,
>         fff varchar(5) NULL,
>         link numeric(8, 0) NOT NULL,
> 	rrr varchar(1) NULL,
>         ident varchar(20) NULL,
> 	xxx varchar(1) NULL,
>         cnty varchar(3) NULL,
> 	zzz varchar(5) NULL,
>         hhh varchar(12) NULL,
> 	ccc varchar(12) NULL,
>         date1 datetime NULL,
> 	date2 datetime NULL,
>         id2 varchar(9) NULL,
> 	ind varchar(1) NULL,
>         eee varchar(1) NULL,
> 	xref varchar(12) NULL
> )
> 
> Anyone have any ideas why I'm seeing these errors? Many thanks.
> 

Mime
View raw message