Hey Abe - 

I haven't because I'm working on running a real lean install on a ARM cluster.

I want a bare bones build (Hadoop, Hive & Scoop).  Starting to feel that although these packages are open source (Hadoop, Hive, Sqoop, etc), figuring out how to build a solution from the bottom, w/o a full package (Bigtop, Cloudera, MapR, Horton, et al), is quite hard, due to not knowing what dependencies are required.

The Doc's of Sqoop 1.4.4 don't mention Hbase being required. What am I missing?

Anyone tried running a barebones setup and know what I'm missing?

Thanks Abe for the tip, I've your distro on a VM and it has all the bells and whistles, just was hoping to get a three node solution running swell with the barebones, just can't figure out what base packages are needed to tie SS 2012/14 and a cluster together with only Hadoop, Hive and Sqoop.

Also I forgot to mention, when I run sqoop help it also says something about missing a Java class.  I've OpenJDK running, pointing to ARM (i.e. export JAVA_HOME=/usr/lib/jvm/java-7-openjdk-armhf)

Thanks to all in advance for your suggestions!


On Oct 28, 2013, at 6:20 PM, "Abraham Elmahrek" <abe@cloudera.com> wrote:


Have you tried installing using Apache Bigtop? or some other packaged installation provider? Hbase client libs are used for Hbase import. Sqoop is compiled with Hbase support I think.


On Mon, Oct 28, 2013 at 4:04 PM, Andrew Allaway <andrewallaway@outlook.com> wrote:
Sorry for the bad title:)

3 nodes
Hadoop 1.2.1
Hive 0.11.0

All's working great:)

Want to connect SQL Server 2012 and SQL Serv. 2014 CTP to the above

I'm totally lost

Namenode (aka node1):

Have Windows7 (static ip4, connected via ethernet thru a switch. I can ssh into nodes 1-3 easy.

All's swell.

On Win7 have a full sql server instance "bob", database "test_db", schema "test_schema" & table "test_table" login "abc" pw "xyz".

On the cluster I've hadoop here:

Just untared Scoop to /usr/lib/sqoop

Then when I tried to run$ sqoop help from the above dir, it said it didn't know where my hadoop was.  So I ran the hadoop_home /usr/local....

Then ran$ sqoop help and it said it can't find hdfs.  So I ran the same$ export home_hdfs usr/local....

Then ran sqoop help and it said it needs Hbase????

Does it?  Why does it need Hbase to run?

Not sure how to go from here.  I want to install these packages as I learn them. I don't intend to learn Hbase at the moment, can I "live" w/o it?

Even if sqoop worked I still don't understand how to pull the table above (test_table) into hdfs and into Hive??