sqoop-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Raj Hadoop <hadoop...@yahoo.com>
Subject Re: Sqoop connection to MS SQL Server
Date Mon, 18 Nov 2013 19:21:10 GMT
Thanks Martin. I tried with the SCHEMA.TABLE_NAME. Did not worked.






On Monday, November 18, 2013 2:05 PM, "Martin, Nick" <NiMartin@pssd.com> wrote:
 
I hit this when first starting out on Sqoop and using –table SCHEMA.TABLE_NAME worked for
me. 
 
If I don’t specify the schema I get the same “unable to find object” kickback. 
 
Give that a shot?
 
From:Raj Hadoop [mailto:hadoopraj@yahoo.com] 
Sent: Monday, November 18, 2013 2:02 PM
To: Sqoop
Subject: Sqoop connection to MS SQL Server
 
 
I am getting error messages while connecting to a MS SQL Server running on a VM which has
multiple instances.
 
If it is a single machine and single instance - I could sucessfully run through the following
command.
 
sqoop import --connect 'jdbc:sqlserver://ABC_SERVER:1433;username=u1;password=pass1;database=cust'
--table CUST_INFO --hive-table CUST_INFO --hive-import --verbose
 
But if I have to connect to specific instances like this -
sqoop import --connect 'jdbc:sqlserver://ABC_SERVER:1433/Instance_Name1;username=u1;password=pass1;database=cust'
--table CUST_INFO --hive-table CUST_INFO --hive-import --verbose
 
I am getting the error like -
Unable to find the object CUST_INFO
 
Are there any known issues while connecting to a MS SQL Server ( VM and multiple instances).
Please advise.
Mime
View raw message