sqoop-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Raj Hadoop <hadoop...@yahoo.com>
Subject Re: AW: Sqoop connection to MS SQL Server
Date Tue, 19 Nov 2013 15:01:06 GMT
It did not worked with a backslash.





On Monday, November 18, 2013 5:06 PM, "Kallinteris, Christos" <kallinteris@initions.com>
wrote:
 
Hello Raj,
 
I’m pretty sure you need a backslash in front of the instance name instead of a slash 
 
Please try
 
sqoop import --connect 'jdbc:sqlserver://ABC_SERVER:1433\Instance_Name1;username=u1;password=pass1;database=cust'
--table CUST_INFO --hive-table CUST_INFO --hive-import --verbose
 
and let us know how it went.
 
Cheers!
 
Christos
--
 
initions AG
Christos Kallinteris
Weidestraße 120a
D-22083 Hamburg

t:   +49 (0) 40 / 41 49 60-79
f:   +49 (0) 40 / 41 49 60-11
e:  kallinteris@initions.com
w: www.initions.com
 
 
Vollständiger Name der Gesellschaft: initions innovative IT solutions AG
Sitz der Gesellschaft: Hamburg
Handelsregister Hamburg B 83929
Aufsichtsratsvorsitzender: Dr. Michael Leue
Vorstand: Dr. Stefan Anschütz, André Paul Henkel, Dr. Helge Plehn
 
Von:Raj Hadoop [mailto:hadoopraj@yahoo.com] 
Gesendet: Montag, 18. November 2013 20:21
An: Martin, Nick; user@sqoop.apache.org
Betreff: Re: Sqoop connection to MS SQL Server
 
Thanks Martin. I tried with the SCHEMA.TABLE_NAME. Did not worked.
 
 
On Monday, November 18, 2013 2:05 PM, "Martin, Nick" <NiMartin@pssd.com> wrote:
I hit this when first starting out on Sqoop and using –table SCHEMA.TABLE_NAME worked for
me. 
 
If I don’t specify the schema I get the same “unable to find object” kickback. 
 
Give that a shot?
 
From:Raj Hadoop [mailto:hadoopraj@yahoo.com] 
Sent: Monday, November 18, 2013 2:02 PM
To: Sqoop
Subject: Sqoop connection to MS SQL Server
 
 
I am getting error messages while connecting to a MS SQL Server running on a VM which has
multiple instances.
 
If it is a single machine and single instance - I could sucessfully run through the following
command.
 
sqoop import --connect 'jdbc:sqlserver://ABC_SERVER:1433;username=u1;password=pass1;database=cust'
--table CUST_INFO --hive-table CUST_INFO --hive-import --verbose
 
But if I have to connect to specific instances like this -
sqoop import --connect 'jdbc:sqlserver://ABC_SERVER:1433/Instance_Name1;username=u1;password=pass1;database=cust'
--table CUST_INFO --hive-table CUST_INFO --hive-import --verbose
 
I am getting the error like -
Unable to find the object CUST_INFO
 
Are there any known issues while connecting to a MS SQL Server ( VM and multiple instances).
Please advise.
Mime
View raw message