sqoop-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Christopher Jones <chrisjones.lam...@gmail.com>
Subject Sqoop 2 Oracle JDBC connector not visible / available
Date Wed, 13 Nov 2013 18:04:13 GMT
Hi Sqoopers,

I'm using Sqoop 2 and am trying to transfer some Oracle 11g tables to HDFS.
 I believe I have the jar file where it's supposed to be:

]$ ls /var/lib/sqoop2/ojdbc6-

and it's a non-empty file.  I tried to make sure the jar was on the


However, when I run sqoop2 at the command line, I can only see the generic

$ sqoop2
Sqoop home directory: /usr/lib/sqoop2
Sqoop Shell: Type 'help' or '\h' for help.

sqoop:000> show connector --all
1 connector(s) to show:
Connector with id 1:
  Name: generic-jdbc-connector
 Class: org.apache.sqoop.connector.jdbc.GenericJdbcConnector
  Version: 1.99.2-cdh4.4.0
  Supported job types: [IMPORT, EXPORT]

Shouldn't I be seeing the Oracle connector as well?

I'm using the following version:

sqoop:000> show version
client version:
  Sqoop 1.99.2-cdh4.4.0 revision
  Compiled by jenkins on Tue Sep  3 20:15:11 PDT 2013

Thanks for your help, and for all the hard work,

View raw message