Jarek, thanks so much for the reply!  This makes total sense to me now.


On Wed, Nov 13, 2013 at 5:23 PM, Jarek Jarcec Cecho <jarcec@apache.org> wrote:
Hi Chris,
I'm excited to see your interest in Sqoop2! I believe that you've done everything correctly and that the output is expected. The reason for that is the difference between "connector" and "driver". You might find more details about the difference in our blog [1]. The article is written for Sqoop 1, but the same concepts applies to Sqoop2. To make the story short - Connectors usually came with Sqoop and are the thing you can see after calling "show connector -a", JDBC Drivers are something that is required by the connectors in order to do the work and you have to install them manually (licensing issues). So in your case Sqoop 2 already came with a "Generic JDBC Connector" and you've just installed an Oracle "JDBC Driver".


1: https://blogs.apache.org/sqoop/entry/connectors_and_drivers_in_the

On Wed, Nov 13, 2013 at 01:04:13PM -0500, Christopher Jones wrote:
> Hi Sqoopers,
> I'm using Sqoop 2 and am trying to transfer some Oracle 11g tables to HDFS.
>  I believe I have the jar file where it's supposed to be:
> ]$ ls /var/lib/sqoop2/ojdbc6-
> /var/lib/sqoop2/ojdbc6-
> and it's a non-empty file.  I tried to make sure the jar was on the
> $ echo $CLASSPATH
> /etc/hadoop/conf:/usr/lib/hadoop/lib/*:/usr/lib/hadoop/.//*:/usr/lib/hadoop-hdfs/./:/usr/lib/hadoop-hdfs/lib/*:/usr/lib/hadoop-hdfs/.//*:/usr/lib/hadoop-yarn/lib/*:/usr/lib/hadoop-yarn/.//*:/usr/lib/hadoop-0.20-mapreduce/./:/usr/lib/hadoop-0.20-mapreduce/lib/*:/usr/lib/hadoop-0.20-mapreduce/.//*:/var/lib/sqoop2/ojdbc6-
> However, when I run sqoop2 at the command line, I can only see the generic
> connector:
> $ sqoop2
> Sqoop home directory: /usr/lib/sqoop2
> Sqoop Shell: Type 'help' or '\h' for help.
> sqoop:000> show connector --all
> 1 connector(s) to show:
> Connector with id 1:
>   Name: generic-jdbc-connector
>  Class: org.apache.sqoop.connector.jdbc.GenericJdbcConnector
>   Version: 1.99.2-cdh4.4.0
>   Supported job types: [IMPORT, EXPORT]
> (...)
> Shouldn't I be seeing the Oracle connector as well?
> I'm using the following version:
> sqoop:000> show version
> client version:
>   Sqoop 1.99.2-cdh4.4.0 revision
>   Compiled by jenkins on Tue Sep  3 20:15:11 PDT 2013
> Thanks for your help, and for all the hard work,
> Chris