sqoop-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Josh Millstein <joshua.millst...@gmail.com>
Subject Re: installing sqoop2 (1.993) on mac osx from source code
Date Mon, 09 Jun 2014 19:59:38 GMT
ah ha, thank you !  yes, I typed the command you gave me and I'm in the
interactive sqoop shell now.  I tried running my 1.44 command from the
sqoop shell and that's definitely not working anymore

import --connect jdbc:mysql://wolfs-MacBook-Pro.local:3306/joshLocal
--username sqoop --password sqoop --table BITLOG --verbose

What is the sqoop2 command for what I'm trying to do?


Thanks again



On Mon, Jun 9, 2014 at 2:37 PM, vasanth kumar <rj.vasanthkumar@gmail.com>
wrote:

> Hi Josh,
>
>  After "mvn package -Pbinary" command.  Inside
> "/usr/local/test/sqoop2/dist/target" you can find
> "sqoop-2.0.0-SNAPSHOT-bin-hadoop200" directory and get into bin directory.
> Start "./sqoop.sh client".
>
>
>
> On Tue, Jun 10, 2014 at 12:05 AM, Josh Millstein <
> joshua.millstein@gmail.com> wrote:
>
>> Hello All -
>>
>> I believe I've managed to figure out that sqoop 1.44 is not compatible
>> with hadoop2.4.  So, I've been trying to install swoop 1.993 to my mac (osx
>> 10.9).   What I've done so far
>>
>> 1) pulled the 1.993 repo from git
>> 2) mvn compile
>> 3) mvn install
>> 4) mvn package
>>
>> when I do a
>>
>> 'which sqoop'
>>
>> I get nothing... same for 'which sqoop2'
>>
>> I then went hunting around for the sqoop.sh client and found it in
>> /usr/local/test/sqoop2/dist/src/main/bin
>>
>> tried to run ./sqoop.sh client
>>
>> and I get a --
>>
>> Sqoop home directory: /usr/local/test/sqoop2/dist/src/main
>> Exception in thread "main" java.lang.NoClassDefFoundError:
>> org/apache/sqoop/shell/SqoopShell
>> Caused by: java.lang.ClassNotFoundException:
>> org.apache.sqoop.shell.SqoopShell
>> at java.net.URLClassLoader$1.run(URLClassLoader.java:202)
>>  at java.security
>>
>> ---
>>
>> I've seen about 100 variations on how to install from source and I can't
>> pin down what I'm doing wrong.  Can anybody help with this?  Also, when I
>> had sqoop 1.44 I was running the following command...
>>
>> sqoop import --connect jdbc:mysql://wolfs-MacBook-Pro.local:3306/joshLocal --username
sqoop --password sqoop --table BITLOG --verbose
>>
>>
>> can you still invoke sqoop like that in 1.993 ?
>>
>>
>>  Thanks in advance for any help.
>>
>>
>> :)
>>
>> Josh
>>
>>
>
>
> --
> Regards
> Vasanth kumar RJ
>

Mime
View raw message