sqoop-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Venkat, Ankam" <Ankam.Ven...@centurylink.com>
Subject Sqoop Import Error from Mainframe DB2
Date Thu, 24 Jul 2014 20:04:58 GMT
I need to import data from Mainframe DB2 to Hadoop using Sqoop.  I am getting below errors.
 Any help on this highly appreciated.

With command  -->  sqoop list-databases --connect jdbc:db2://xxxxxx.com:455/ --username
XXXXX --password YYYYY
Error: Caused by: com.ibm.db2.jcc.am.SqlSyntaxErrorException: [jcc][10165][10047][4.14.111]
Invalid database URL syntax: jdbc:db2://d1vipa.corp.intranet:455/. ERRORCODE=-4461, SQLSTATE=42815

With command  --> sqoop list-databases --connect jdbc:db2:@xxxxxx.com:455/ --username XXXXX
--password YYYYY
Error: Caused by: com.ibm.db2.jcc.am.SqlException: [jcc][10389][12245][4.14.111] Failure in
loading native library db2jcct2, java.lang.UnsatisfiedLinkError: no db2jcct2 in java.library.path:
 ERRORCODE=-4472, SQLSTATE=null

Downloaded DB2 Version 10.1 JDBC driver (both 3.0 and 4.0) and after extracting I see two
jar files (db2jcc4.jar and db2jcc.jar).

I copied db2jcc4.jar to /opt/cloudera/parcels/CDH-5.0.0-1.cdh5.0.0.p0.47/lib/sqoop/lib and
then tried above two commands.  Tried with db2jcc.jar as well but getting same errors.  Tried
copying these jars from both 3.0 and 4.0 versions after deleting the earlier JDBC.

Mainframe DB2 version is 10.1 and My Sqoop version is Sqoop 1.4.4-cdh5.0.0.

Any quick help?

Thanks in advance.

Regards,
Venkat Ankam

Mime
View raw message