sqoop-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Abraham Elmahrek <...@cloudera.com>
Subject Re: sqoop 1.4.5 for hadoop 2.4 question (can't find method)
Date Mon, 17 Nov 2014 17:37:02 GMT
You shouldn't need to change the versions in build.xml. If should just work
out of the box with any Hadoop 2 distribution.

-Abe

On Mon, Nov 17, 2014 at 2:33 AM, lu <chiahung1227@gmail.com> wrote:

> hi ,
> i download sqoop-1.4.5.tar.gz ,and modified build.xml
> (just change hadoop version to 2.4.1 )
> <equals arg1="${hadoopversion}" arg2="200" />
>       <then>
>         <property name="hadoop.version" value="2.4.1" />
>         <property name="hbase94.version" value="0.94.2" />
>         <property name="zookeeper.version" value="3.4.2" />
>         <property name="hadoop.version.full" value="2.4.1" />
>         <property name="hcatalog.version" value="0.13.0" />
>         <property name="hbasecompatprofile" value="2" />
>         <property name="avrohadoopprofile" value="2" />
>       </then>
>
> after build and install
> i try to convert data from mysql to hdfs
> "sqoop import --connect jdbc:mysql://localhost:3306/test --username xxx
> --password xxxx --table user1 -m 1 --verbose"
> it's appear
>
> *Exception in thread "main" java.lang.NoSuchMethodError:
> org.apache.hadoop.http.HttpConfig.getSchemePrefix()Ljava/lang/String;*
>
> this method seem to change in hadoop 2.4
> how can i fix this bug and if sqoop 1.4.5 can support hadoop 2.4.1?
> i can't find solution on web
>
>
> Thank you!
>
> Luke
>

Mime
View raw message