sqoop-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Vineet Mishra <clearmido...@gmail.com>
Subject Re: Sqoop Free Form Import Query Breaks off
Date Thu, 25 Dec 2014 20:39:21 GMT
Hi Abe,

Thanks for your quick suggestion, even I already tried this as well and
unfortunately this too didn't worked for my case.

At last I got a work around to the problem, I got a understanding that
since its was working fine given the same command through command terminal
and was breaking when I was invoking it through Java Process exec(),(since
splitting around spaces and executing script on top of that) so I just
dumped the piece of code to a xyz.sh file and finally executed that file
itself.

It worked like a charm.

Anyways thanks Abe for your effective and quickest response.
______________________________________________________________________________
Apologies to the cassandra group, for accidentally posting sqoop question
in cassandra mailing list.

On Fri, Dec 26, 2014 at 12:53 AM, Abraham Elmahrek <abe@cloudera.com> wrote:

> Seems like exec parses the command with StringTokenizer [1]. This may have
> some difficulty parsing with quotes. Try using the array form of this
> command to explicitly define your String tokens [2].
>
> Ref:
> 1.
> http://docs.oracle.com/javase/7/docs/api/java/lang/Runtime.html#exec(java.lang.String,%20java.lang.String[],%20java.io.File)
> 2.
> http://docs.oracle.com/javase/7/docs/api/java/lang/Runtime.html#exec(java.lang.String[],%20java.lang.String[],%20java.io.File)
>
> -Abe
>
> On Thu, Dec 25, 2014 at 5:24 AM, Vineet Mishra <clearmidoubt@gmail.com>
> wrote:
>
>> exec
>
>
>
>

Mime
View raw message