sqoop-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Giovanni M.L.G." <giovanni.gargi...@gmail.com>
Subject Sqoop Oracle and MS Access
Date Fri, 06 Nov 2015 08:32:59 GMT
Hi,

I've been using sqoop for a while and have recently come across two issues:


   1. We have a use case where we import data as avro from an oracle
   database (so it's a standard use case).

   The problem is that there are really a lot of tables, and most of these
   tables contain fields with "strange" types such as "Timestamp(6) with
   Timezone".

   By default sqoop complains about these fields and breaks, unless one
   manually specifies how to convert these columns with "--map-column-java".
   (We tried this for a few tables, mapping unsupported types to String).

   As I mentioned the number of tables is so large that using this
   workaround is not a viable option.

   Is there a way to tell sqoop to convert unknown types to String when
   importing as avro? [I couldn't find anything on the documentation].


   2. Another use case we are facing is importing data from Microsoft
   Access Dbs. Is there a way to do this with sqoop? [I tried using a few jdbc
   drivers for Access, but with no success]


Thanks for the support!

Cheers,


GG

Mime
View raw message