sqoop-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Giovanni M.L.G." <giovanni.gargi...@gmail.com>
Subject Re: Sqoop Oracle and MS Access
Date Mon, 09 Nov 2015 09:29:36 GMT
Hi David and Sumit,

thanks for the quick answer.

Regarding oracle:


we are using sqoop 1.4.5-cdh5.4.4 with the --direct option. We have no
problem importing dates and timestamps with no timezone info.

The problem comes in when timezone info is there [We get something like
"Cannot convert SQL-type -102" error].
The only workoround we found is the one i mentioned [using
--map-column-java].


Do you think things change with sqoop 1.4.6?

Regarding Access:


our use case is the following: an .mdb or .accdb file gets shipped to a
node in our cluster with sftp [we can't connect directly to the windows
server] and we should import all the tables in that file into hive.

I haven't tried the easysoft driver because it seemed that it required the
.mdb to be in a windows server


I have tried with the UCanAccess jdbc driver.


Since the access db file is actually already in our cluster I don't even
know if sqoop would be the right tool for reading the data from it.

Any suggestions would be greatly appreciated.

Cheers,

GG

Mime
View raw message