sqoop-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Anna Szonyi <szo...@cloudera.com>
Subject Re: Compile sqoop with latest hive version (2.1.0)
Date Sat, 03 Dec 2016 11:16:21 GMT
Hi,

This is an issue with newer versions of hive (0.14+) introducing Calcite,
which depends on the org.pentaho#pentaho-aggdesigner-algorithm lib, which
is unfortunately not available in the Central maven repo, only in conjars
and spring-plugins.

On the other hand I don't think Sqoop will work out of the box with hive
2+, as there will probably have to be code changes made to accommodate the
changes made to hive - however I've not tested this myself.

If you would like to test with these versions however, you could add a
conjars resolver to your ivysettings file
 <ibiblio name="conjars" m2compatible="true" root="http://conjars.org/repo/"
/> + add conjars to the resolution chain and it should work.

Regards,
/Anna


On Sun, Nov 27, 2016 at 4:27 PM, Dima Fadeyev <linuxremote@gmail.com> wrote:

> Hello, everyone,
>
> I'm trying to compile sqoop with hive 2.1.0:
>
> ant package -Dhadoop.version=2.7.3 -Dhcatalog.version=2.1.0
>
> I'm getting this error:
>
> [ivy:resolve]       http://repo1.maven.org/maven2/org/pentaho/pentaho-
> aggdesigner-algorithm/5.1.5-jhyde/pentaho-aggdesigner-
> algorithm-5.1.5-jhyde.jar
> [ivy:resolve]         ::::::::::::::::::::::::::::::::::::::::::::::
> [ivy:resolve]         ::          UNRESOLVED DEPENDENCIES         ::
> [ivy:resolve]         ::::::::::::::::::::::::::::::::::::::::::::::
> [ivy:resolve]         :: org.pentaho#pentaho-aggdesigner-algorithm;5.1.5-jhyde:
> not found
> [ivy:resolve]         ::::::::::::::::::::::::::::::::::::::::::::::
>
>
> Is it possible to build sqoop with hive 2.1.0? Am I doing it wrong?
>
> Thanks and best regards.
>

Mime
View raw message