storm-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Stig Rohde Døssing (JIRA) <j...@apache.org>
Subject [jira] [Resolved] (STORM-3312) Upgrade Guava to latest
Date Fri, 15 Mar 2019 21:03:00 GMT

     [ https://issues.apache.org/jira/browse/STORM-3312?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Stig Rohde Døssing resolved STORM-3312.
---------------------------------------
       Resolution: Fixed
    Fix Version/s: 2.0.0

> Upgrade Guava to latest
> -----------------------
>
>                 Key: STORM-3312
>                 URL: https://issues.apache.org/jira/browse/STORM-3312
>             Project: Apache Storm
>          Issue Type: Dependency upgrade
>    Affects Versions: 2.0.0
>            Reporter: Stig Rohde Døssing
>            Assignee: Stig Rohde Døssing
>            Priority: Minor
>              Labels: pull-request-available
>             Fix For: 2.0.0
>
>          Time Spent: 3h 40m
>  Remaining Estimate: 0h
>
> As part of STORM-3311, I want to use https://google.github.io/guava/releases/23.0/api/docs/com/google/common/io/MoreFiles.html
to replace Guava's Files class. We're currently on Guava 16.0.1, which is too old. Since we're
shading Guava, there shouldn't be an issue with upgrading it. Modules like storm-cassandra
that require old Guava versions can depend directly on unshaded Guava in the version they
like.



--
This message was sent by Atlassian JIRA
(v7.6.3#76005)

Mime
View raw message