storm-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Jungtaek Lim (JIRA)" <j...@apache.org>
Subject [jira] [Resolved] (STORM-3352) Use Netty BOM to lock all Netty artifacts to same version
Date Sat, 16 Mar 2019 03:25:00 GMT

     [ https://issues.apache.org/jira/browse/STORM-3352?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Jungtaek Lim resolved STORM-3352.
---------------------------------
       Resolution: Fixed
    Fix Version/s: 2.0.0

Thanks [~Srdo] I merged into master.

> Use Netty BOM to lock all Netty artifacts to same version
> ---------------------------------------------------------
>
>                 Key: STORM-3352
>                 URL: https://issues.apache.org/jira/browse/STORM-3352
>             Project: Apache Storm
>          Issue Type: Bug
>    Affects Versions: 2.0.0
>            Reporter: Stig Rohde Døssing
>            Assignee: Stig Rohde Døssing
>            Priority: Blocker
>              Labels: pull-request-available
>             Fix For: 2.0.0
>
>          Time Spent: 1.5h
>  Remaining Estimate: 0h
>
> We are not properly ensuring that Netty artifacts are the same version. I got a test
failure in storm-cassandra, because netty-all is version 4.1.30, but cassandra pulls in Netty
in version 4.0.37.
> {quote}
> java.lang.NoSuchMethodError: io.netty.util.internal.PlatformDependent.normalizedArch()Ljava/lang/String;
>     at io.netty.channel.epoll.Native.loadNativeLibrary(Native.java:180) ~[netty-all-4.1.30.Final.jar:4.1.30.Final]
>     at io.netty.channel.epoll.Native.<clinit>(Native.java:61) ~[netty-all-4.1.30.Final.jar:4.1.30.Final]
>     at io.netty.channel.epoll.Epoll.<clinit>(Epoll.java:38) ~[netty-all-4.1.30.Final.jar:4.1.30.Final]
>     at org.apache.cassandra.transport.Server.run(Server.java:147) ~[cassandra-all-2.1.7.jar:2.1.7]
> {quote}



--
This message was sent by Atlassian JIRA
(v7.6.3#76005)

Mime
View raw message