storm-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Kashyap Mhaisekar <kashya...@gmail.com>
Subject RE: Logging issues in Storm
Date Sat, 05 Apr 2014 18:39:00 GMT
Thanks for the direction. I don't see my logs there. I am still to try out
modifying the cluster XML for adding additional appenders.

Do the logs come in the worker logs even if it is a local cluster mode too?

Thanks!
Kashyap
On Apr 5, 2014 10:12 AM, "Poling, Raymond" <raymond.poling@citi.com> wrote:

>  Try looking under $STORM_HOME/logs/worker-SLOT.log for the worker that
> is running your code. SL4j and log4j get bridged back to Storm's native
> logback logger.
>
>
>
> *From:* Kashyap Mhaisekar [mailto:kashyap.m@gmail.com]
> *Sent:* Saturday, April 05, 2014 9:10 AM
> *To:* user@storm.incubator.apache.org
> *Subject:* Logging issues in Storm
>
>
>
> Hi,
>
> For making Log4j logs to work in storm, what needs to be done?
>
> I have used both Slf4j and Log4j directly and it works when executed as a
> standalone java program (Logs get printed where they need to). However, the
> moment I submit cluster (StormSubmitter) or LocalCluster, the logs dont
> appear.
>
>
>
> Even Sysouts dont get printed. I see some of the sysouts in Supervisor.log
> but the sysouts from spouts and bolts are not there anywhere.
>
>
>
> I came across cluster.xml under .../storm/logback which seems to indicate
> all loggers should be configured here?
>
>
>
> Any ideas on what I might be missing?
>
>
>
> Regards,
>
> Kashyap
>

Mime
View raw message