storm-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Webb, Ryan L." <Ryan.W...@jhuapl.edu>
Subject RE: Testing Utility Timeouts
Date Sun, 01 Feb 2015 03:09:58 GMT
I am using backtype.storm.Testing#withLocalCluster(MkClusterParam, TestJob) and in my Test
Job I use Testing#completeTopology(ILocalCluster, StormTopology, CompleteTopologyParam).

It looks like the Java API in fell behind the clojure one in .9.3. There is a fix in .10 that
has the ability to pass a timeout in the CompleteTopologyParam.

Thanks
Ryan Webb
From: Harsha [mailto:storm@harsha.io]
Sent: Friday, January 30, 2015 12:46 PM
To: user@storm.apache.org
Subject: Re: Testing Utility Timeouts

If you are looking to increase unit tests time out please take a look at this section
https://github.com/apache/storm/blob/master/DEVELOPER.md#build-the-code-and-run-the-tests
"Is there a way to increase/turn off the timeout for the testing topology?"
which testing topology you are referring too. It might be that its getting submitted to a
LocalCluster and than getting killed after 5 secs. You can increase the time in the code.
-Harsha


On Fri, Jan 30, 2015, at 09:27 AM, Webb, Ryan L. wrote:

Hey Guys,



I am attempting to use the testing utility to do some more formal unit tests but I keep having
issues where some times it beats the 5 second timeout and other times it doesn't.



Is there a way to increase/turn off the timeout for the testing topology?



Thanks

Ryan Webb


Mime
View raw message