storm-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Hugo Da Cruz Louro <hlo...@hortonworks.com>
Subject Re: Thread[main,5,main] died
Date Wed, 09 Dec 2015 22:58:20 GMT
Can you restart the machine? If there is any lingering process rebooting will take care of
it.

you got command not found because the single quotation mark got replaced by a similar but
different character by the text editor.  if you use that same command replacing the single
quotation marks with your keyboard (instead of pasting) the command will work.

To make sure you can also try

ps -ef | grep -i zmq

But reboot will help you be sure


On Dec 9, 2015, at 2:44 PM, askr askor <askraskor@gmail.com<mailto:askraskor@gmail.com>>
wrote:

thanks i tried the command and got ps -ef | grep -iE ‘zeromq|zmq’
zmq’: command not found

but tried this and got
user@user:~$ ps -ef | grep -iE ‘zeromq’
user      5357  5276  0 00:43 pts/0    00:00:00 grep --color=auto -iE ‘zeromq’

please what should i do ?


On Wed, Dec 9, 2015 at 9:44 PM, Hugo Da Cruz Louro <hlouro@hortonworks.com<mailto:hlouro@hortonworks.com>>
wrote:
Ideally you should use the most recent stable release of Storm, which is 0.10. You can downloaded
from here: http://storm.apache.org/downloads.html

The Address already in use is most likely caused by a background process that is using that
port. You can try finding and kill the process

ps -ef | grep -iE ‘zeromq|zmq’ may help you find the PID.

Thanks,
Hugo

On Dec 9, 2015, at 8:48 AM, askr askor <askraskor@gmail.com<mailto:askraskor@gmail.com>>
wrote:

version storm -0.8.2
sorry what do you mean by version of topologies and nodes ?

i restarted storm again , but this error disappeared and got another
org.zeromq.ZMQException: Address already in use(0x62)
    at org.zeromq.ZMQ$Socket.bind(Native Method)

i'm on ubuntu 14.04
what is your version of ubuntu do you have ?

On Wed, Dec 9, 2015 at 6:38 PM, 임정택 <kabhwan@gmail.com<mailto:kabhwan@gmail.com>>
wrote:
Could you share your Storm version?
And could you check that all cluster nodes & topologies are using same version?

Best,
Jungtaek Lim (HeartSaVioR)

2015-12-09 23:57 GMT+09:00 askr askor <askraskor@gmail.com<mailto:askraskor@gmail.com>>:
can anybody help ?

On Wed, Dec 9, 2015 at 5:04 AM, askr askor <askraskor@gmail.com<mailto:askraskor@gmail.com>>
wrote:
i'm new to storm , i faced problem in worker log file NIOServerCnxn [ERROR] Thread Thread[main,5,main]
died clojure.lang.ArityException: Wrong number of args (3) passed to: worker$-main     at
clojure.lang.AFn.throwArity(AFn.java:437)     at clojure.lang.AFn.invoke(AFn.java:47)    
at clojure.lang.AFn.applyToHelper(AFn.java:167)     at clojure.lang.AFn.applyTo(AFn.java:151)
    at backtype.storm.daemon.worker.main(Unknown Source)  how can i fix it ?




--
Name : 임 정택
Blog : http://www.heartsavior.net<http://www.heartsavior.net/> / http://dev.heartsavior.net<http://dev.heartsavior.net/>
Twitter : http://twitter.com/heartsavior
LinkedIn : http://www.linkedin.com/in/heartsavior




Mime
View raw message