storm-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From sam mohel <sammoh...@gmail.com>
Subject Re: WHERE can i find help ?
Date Sun, 13 Dec 2015 06:41:21 GMT
just i want to say that i'm using wi-fi connection in the laptop is it a
problem or not ? and here what i checked for port 6703

i used

netstat -ntape

and got
tcp        0      0 127.0.1.1:53            0.0.0.0:*
LISTEN      0          16962       -
tcp        0      0 127.0.0.1:631           0.0.0.0:*
LISTEN      0          18450       -
tcp        0      0 0.0.0.0:25              0.0.0.0:*
LISTEN      0          421125      -
tcp        0      0 0.0.0.0:6627            0.0.0.0:*
LISTEN      1000       472058      21289/java
tcp        0      0 0.0.0.0:6703            0.0.0.0:*
LISTEN      1000       474108      21640/java
tcp6       0      0 ::1:631                 :::*
LISTEN      0          18449       -
tcp6       0      0 :::25                   :::*
LISTEN      0          421126      -
tcp6       0      0 :::3772                 :::*
LISTEN      1000       476278      21431/java
tcp6       0      0 :::3773                 :::*
LISTEN      1000       476282      21431/java
tcp6       0      0 :::41248                :::*
LISTEN      1000       450631      18116/java
tcp6       0      0 :::2181                 :::*
LISTEN      1000       450636      18116/java
tcp6       0      0 :::8080                 :::*
LISTEN      1000       476304      21480/java
tcp6       0     47 127.0.0.1:3773          127.0.0.1:48310
ESTABLISHED 1000       476316      21431/java
tcp6       0      0 127.0.0.1:41595         127.0.0.1:2181
ESTABLISHED 1000       475181      21246/java
tcp6       1      0 ::1:59865               ::1:631
CLOSE_WAIT  0          18085       -
tcp6       0      0 127.0.0.1:2181          127.0.0.1:41598
ESTABLISHED 1000       475244      18116/java
tcp6       0      0 127.0.0.1:2181          127.0.0.1:41595
ESTABLISHED 1000       472998      18116/java
tcp6       0      0 127.0.0.1:2181          127.0.0.1:41601
ESTABLISHED 1000       476248      18116/java
tcp6       0      0 127.0.0.1:2181          127.0.0.1:41613
ESTABLISHED 1000       475312      18116/java


then used

lsof -P -w -n -p 21640 -a -i

and got

COMMAND   PID USER   FD   TYPE DEVICE SIZE/OFF NODE NAME
java    21640 user   76u  IPv4 477354      0t0  TCP 127.0.0.1:41613->
127.0.0.1:2181 (ESTABLISHED)
java    21640 user   82u  IPv4 474105      0t0  TCP 127.0.0.1:48310->
127.0.0.1:3773 (ESTABLISHED)
java    21640 user   85u  IPv4 474108      0t0  TCP *:6703 (LISTEN)

is there any problem ?

and i want to ask about drpc and zookeeper connection should it be using
ipv4 or not ?

On Sun, Dec 13, 2015 at 8:12 AM, sam mohel <sammohel5@gmail.com> wrote:

> the file that it coudn't find it as i think it will not affect in
> submitting
> it's like
> 0 hey
> 1 one
>  1st first
>  2day today
> 2marrow tomorrow
>  and so on
>
> On Sun, Dec 13, 2015 at 8:10 AM, sam mohel <sammohel5@gmail.com> wrote:
>
>> thanks for your time and replying , i imported this project from github
>> can you submit it in your machine and see if it'll work or not ?
>>
>> coder used storm-0.8.2 .. i need to use the old version first so i have
>> to fix this error unfortuantly .
>> i will use your advice 'topology.debug is true" and get back to you
>>
>> here is my storm.yaml
>> storm.zookeeper.servers:
>>      - "127.0.0.1"
>> nimbus.host: "127.0.0.1"
>> storm.local.dir: /home/user/storms/storm
>> supervisor.childopts: "-Djava.net.preferIPv4Stack=true"
>> nimbus.childopts: "-Djava.net.preferIPv4Stack=true"
>> worker.childopts: "-Djava.net.preferIPv4Stack=true"
>> supervisor.slots.ports:
>>     - 6700
>>     - 6701
>>     - 6702
>>     - 6703
>> topology.debug: true
>>
>> i can't find the result of deugging
>>
>> On Sunday, December 13, 2015, saiprasad mishra <saiprasadmishra@gmail.com>
>> wrote:
>>
>>> Oh my bad just saw your worker log some errors in your topology
>>> Some files are missing which your code needs i guess
>>>
>>> 2015-12-11 02:13:35 STDIO [INFO] java.io.FileNotFoundException: oov.txt
>>> (No such file or directory)
>>> 2015-12-11 02:13:35 STDIO [INFO] java.io.FileNotFoundException: oov.txt
>>> (No such file or directory)
>>>
>>> Regards
>>> Sai
>>>
>>> On Sat, Dec 12, 2015 at 7:33 PM, saiprasad mishra <
>>> saiprasadmishra@gmail.com> wrote:
>>>
>>>> This means the worker process is not starting
>>>> I guess some issues with your storm.yaml first to check if there are
>>>> any bad control characters or some thing
>>>> pls make the topology.debug to true and see if it thros some more info
>>>> in your supervisor log
>>>> also pls try to tun ./storm supervisor command to see if it throws
>>>> issues with your storm.yaml file right away
>>>>
>>>> 8.2 is very older version and i sould suggest to to go to some newer
>>>> version like 9.4 though this error has nothing related to that just a
>>>> sugegstion
>>>>
>>>> Regards
>>>> Sai
>>>>
>>>> On Sat, Dec 12, 2015 at 4:35 PM, sam mohel <sammohel5@gmail.com> wrote:
>>>>
>>>>> i forget to write the issues
>>>>> [ERROR] Async loop died!
>>>>> org.zeromq.ZMQException: Address already in use(0x62)
>>>>>     at org.zeromq.ZMQ$Socket.bind(Native Method)
>>>>>     at zilch.mq$bind.invoke(mq.clj:69)
>>>>>     at backtype.storm.messaging.zmq.ZMQContext.bind(zmq.clj:57)
>>>>>     at
>>>>> backtype.storm.messaging.loader$launch_receive_thread_BANG_$fn__1629.invoke(loader.clj:26)
>>>>>     at backtype.storm.util$async_loop$fn__465.invoke(util.clj:375)
>>>>>     at clojure.lang.AFn.run(AFn.java:24)
>>>>>     at java.lang.Thread.run(Thread.java:701)
>>>>>  util [INFO] Halting process:
>>>>>
>>>>>
>>>>> On Sun, Dec 13, 2015 at 2:25 AM, sam mohel <sammohel5@gmail.com>
>>>>> wrote:
>>>>>
>>>>>> really , Thanks for replying
>>>>>> storm version -0.8.2
>>>>>> zookeeper-3.4.7
>>>>>> topology working fine as i thought but supervisor still hasn't start
>>>>>> then work file stop to submit
>>>>>> all of this in the logs i share it here ​
>>>>>>  worker-6703.log
>>>>>> <https://drive.google.com/file/d/0B65y2kHK35yCMUZYMEZHSW1aWE0/view?usp=drive_web>
>>>>>> ​​
>>>>>>  ui.log
>>>>>> <https://drive.google.com/file/d/0B65y2kHK35yCdVhVU245QmtSVzg/view?usp=drive_web>
>>>>>> ​​
>>>>>>  supervisor.log
>>>>>> <https://drive.google.com/file/d/0B65y2kHK35yCYXlOcVpPcHZIcG8/view?usp=drive_web>
>>>>>> ​​
>>>>>>  nimbus.log
>>>>>> <https://drive.google.com/file/d/0B65y2kHK35yCUnU1R0JqRFlVdTA/view?usp=drive_web>
>>>>>> ​​
>>>>>>  drpc.log
>>>>>> <https://drive.google.com/file/d/0B65y2kHK35yCaVR1T2xQOE45M28/view?usp=drive_web>
>>>>>> ​
>>>>>>
>>>>>>
>>>>>> On Sun, Dec 13, 2015 at 1:20 AM, saiprasad mishra <
>>>>>> saiprasadmishra@gmail.com> wrote:
>>>>>>
>>>>>>> Whats the exact issue/exception
>>>>>>> pls share some logs
>>>>>>>
>>>>>>> Is the topology is not getting deployed/started
>>>>>>> Pls share some supervisor logs and worker logs and which version
of
>>>>>>> storm
>>>>>>>
>>>>>>> Regards
>>>>>>> Sai
>>>>>>>
>>>>>>> On Sat, Dec 12, 2015 at 3:09 PM, sam mohel <sammohel5@gmail.com>
>>>>>>> wrote:
>>>>>>>
>>>>>>>> My project is stopped due to error no one couldn't help or
know
>>>>>>>> about it !!!!
>>>>>>>>
>>>>>>>> Where can I post my problem ?????
>>>>>>>> Stackoverflow said ask users-storm and no one know how can
u solve
>>>>>>>> it
>>>>>>>>
>>>>>>>> I have deadline for the project and I finished coding except
I
>>>>>>>> couldn't submit topology
>>>>>>>>
>>>>>>>>
>>>>>>>> Storm ui like this
>>>>>>>>
>>>>>>>>
>>>>>>>> HOPE this time find help
>>>>>>>>
>>>>>>>> ​
>>>>>>>>
>>>>>>>
>>>>>>>
>>>>>>
>>>>>
>>>>
>>>
>

Mime
View raw message