storm-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From researcher cs <prog.researc...@gmail.com>
Subject Failed to bind to: 0.0.0.0/0.0.0.0:6703
Date Mon, 04 Jan 2016 00:09:40 GMT
I'm using storm -0.9.0.1 with zookeeper -3.4.6 ubuntu 14.04
now i ran my topology in local mode with maven commands and worked well
BUT when i submitted it i got

org.jboss.netty.channel.ChannelException: Failed to bind to:
0.0.0.0/0.0.0.0:6703
    at
org.jboss.netty.bootstrap.ServerBootstrap.bind(ServerBootstrap.java:272)
~[netty-3.6.3.Final.jar:na]
    at backtype.storm.messaging.netty.Server.<init>(Server.java:56)
~[storm-netty-0.9.0.1.jar:na]
    at backtype.storm.messaging.netty.Context.bind(Context.java:27)
~[storm-netty-0.9.0.1.jar:na]
    at
backtype.storm.messaging.loader$launch_receive_thread_BANG_$fn__2984.invoke(loader.clj:20)
~[storm-core-0.9.0.1.jar:na]
    at backtype.storm.util$async_loop$fn__444.invoke(util.clj:401)
~[storm-core-0.9.0.1.jar:na]
    at clojure.lang.AFn.run(AFn.java:24) ~[clojure-1.4.0.jar:na]
    at java.lang.Thread.run(Thread.java:701) ~[na:1.6.0_37]
Caused by: java.net.BindException: Address already in use
    at sun.nio.ch.Net.bind0(Native Method) ~[na:1.6.0_37]
    at sun.nio.ch.Net.bind(Net.java:174) ~[na:1.6.0_37]
    at
sun.nio.ch.ServerSocketChannelImpl.bind(ServerSocketChannelImpl.java:139)
~[na:1.6.0_37]
    at sun.nio.ch.ServerSocketAdaptor.bind(ServerSocketAdaptor.java:77)
~[na:1.6.0_37]
    at
org.jboss.netty.channel.socket.nio.NioServerBoss$RegisterTask.run(NioServerBoss.java:193)
~[netty-3.6.3.Final.jar:na]
    at
org.jboss.netty.channel.socket.nio.AbstractNioSelector.processTaskQueue(AbstractNioSelector.java:366)
~[netty-3.6.3.Final.jar:na]
    at
org.jboss.netty.channel.socket.nio.AbstractNioSelector.run(AbstractNioSelector.java:290)
~[netty-3.6.3.Final.jar:na]
    at
org.jboss.netty.channel.socket.nio.NioServerBoss.run(NioServerBoss.java:42)
~[netty-3.6.3.Final.jar:na]
    at
java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1146)
~[na:1.6.0_37]
    at
java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:615)
~[na:1.6.0_37]
    ... 1 common frames omitted
2016-01-04 01:52:07 b.s.util [INFO] Halting process:

the topology using one worker for one supervisor i'm trying to run or
submit it first in single machine

so my only storm.yaml is

storm.zookeeper.servers:
     - "192.168.x.x"
 nimbus.host: "192.168.x.x"
 storm.local.dir: "/var/storm"
 supervisor.childopts: "-Djava.net.preferIPv4Stack=true"
 nimbus.childopts: "-Djava.net.preferIPv4Stack=true"
 worker.childopts: "-Djava.net.preferIPv4Stack=true"
 drpc.servers:
     - "192.168.x.x"
storm.messaging.transport: "backtype.storm.messaging.netty.Context"
 storm.messaging.netty.server_worker_threads: 1
 storm.messaging.netty.client_worker_threads: 1
 storm.messaging.netty.buffer_size: 5242880
 storm.messaging.netty.max_retries: 100
 storm.messaging.netty.max_wait_ms: 1000
 storm.messaging.netty.min_wait_ms: 100

zoo.cfg is

tickTime=2000
initLimit=10
syncLimit=5
dataDir=/var/zookeeper
clientPort=2181

i tried to use localhost but got same error then tried to use my ip address
i searched to fix it more but got this solution
can someone illustrate it beacuse i didn't get it well

[[
It turned out that my logback/cluster.xml configuration had a
SocketAppender that didn't have a listener on the remote host. Having an
appender defined in configuration file, even if it is not set up to receive
any log messages, will cause Storm to block and the above error message.its
due to zookeeper you have add curator separetly not required its the part
of zookeeper
]]

or can someone help me to fix it ?

importaant thing

topology using drpc and i tried to submit another topoogies worked well but
topology with drpc got this error


the project i'm trying to submit it here
https://github.com/mvogiatzis/first-stories-twitter

Mime
View raw message