storm-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Abhishek Agarwal <abhishc...@gmail.com>
Subject Backward compatibility of STORM 1.0.0
Date Wed, 13 Apr 2016 08:16:48 GMT
In the latest version, the class packages have been changed from
"backtype.storm" to "org.apache.storm" so the topology code compiled with
older version won't run on the Storm 1.0.0 just like that. Backward
compatibility is  available through following configuration

*client.jartransformer.class: "org.apache.storm.hack.StormShadeTransformer"*

You need to add the above config in storm installation if you want to run
the code compiled with older versions of storm. The config should be added
in the machine you use to submit your topologies.

Refer to https://issues.apache.org/jira/browse/STORM-1202 for more details.

-- 
Regards,
Abhishek Agarwal

Mime
View raw message