Please check the details in each Spout (click the spout), there has more data for executors, you can find something there, and post the screenshot pls.

 

From: Navin Ipe [mailto:navin.ipe@searchlighthealth.com]
Sent: 2016
61 13:27
To: user@storm.apache.org
Subject: [EXTERNAL] Re: Common for storm UI to not show emits?

 

@Huo: Yes, so the fact that 20 were ack'ed in spouts 1, 2 and 3, should mean that the emits should have also been shown as 20. But the emits are being shown as 0.

One person says only 5% of data is shown by the UI: http://stackoverflow.com/a/36204192/453673

But still, it is a bit odd that the emits didn't show up. btw, the second time the spout emits via allGrouping, it does so in a separate stream.

 

On Wed, Jun 1, 2016 at 7:31 AM, Hao Wang <hwang17@mmm.com> wrote:

It only displays numbers reached 20 at least, and increased per 20. 

From: Navin Ipe [mailto:navin.ipe@searchlighthealth.com]
Sent: 2016
531 20:03
To: user@storm.apache.org
Subject: [EXTERNAL] Common for storm UI to not show emits?

 

Hi,

Screenshot:


I confirmed from the logs that all spouts were emitting and ack'ing. Strangely, the UI doesn't show it. Moreover, Spout 1, 2 and 3 show no emissions but there are ack's. Is it common for Storm to show results like this?

Here, 10 spouts emit to a bolt (which run as 4 tasks) via fieldsGrouping. The bolt ack's. After each spout receives 20 ack's from the bolt, the spout emits to the bolt again using allGrouping.


--

Regards,

Navin

 

 
3M security scanners have not detected any malicious content in this message.
Click here to report this email as spam
 

 




--

Regards,

Navin

 

 
3M security scanners have not detected any malicious content in this message.
Click here to report this email as spam