storm-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Junfeng Chen <k-2f...@hotmail.com>
Subject Re: KafkaSpout offset stored under wrong partition in zookeeper
Date Wed, 19 Oct 2016 09:13:41 GMT
Can you provide your KafkaSpout configuration?


Regard,
Junfeng Chen

On Wed, Oct 19, 2016 at 5:07 PM, Daniccan VP <daniccan@iqsystech.com> wrote:

> Hi,
>
> I am running a Storm Topology with a KafkaSpout which consumes messages
> from Kafka Brokers. The issue I am facing is that the assigned partition
> for a worker process and the partition and offset information of the
> consumer stored in zookeeper are different.
>
> For example, One of the worker processes is assigned with a partition id
> of 1. But, it keeps searching for the last offset under partition 2 in
> Zookeeper path. Has anyone else faced a similar issue ?
>
> Thanks and Regards,
> *Daniccan VP **|* *Junior Software Engineer*
> Email : daniccan@iqsystech.com
> ************************************************************
> ************************************************************
> ******************************************* This email and any files
> transmitted with it are confidential and intended solely for the use of the
> individual or entity to whom they have been addressed. If you are not the
> intended recipient, you are notified that disclosing, copying, distributing
> or taking any action in reliance on the contents of this information is
> strictly prohibited. Please notify the sender immediately by e-mail if you
> have received this e-mail by mistake and delete this e-mail from your
> system.
>

Mime
View raw message