storm-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Sudha Subramanian <sudha...@gmail.com>
Subject Issue with Storm 1.0.2 on docker
Date Wed, 12 Oct 2016 04:08:11 GMT
Hi,

I'm running Storm 1.0.2 components in docker container all on the same VM.

I'm running into an issue where based on the configuration of storm.yaml
and container host name, I can either get the storm command line to work,
or the Storm UI to connect But, not both.

Following configuration allows me to use storm command line and perform
commands like list and jar.

Storm.yaml:

                      storm.zookeeper.servers:

                                - 172.x.x.x
                         nimbus.seeds: ["*104.10.x.x*"]

>

 Where, 172.x.x.x -> is the docker IP address where zookeeper runs

    and   104.10.x.x -> is the external IP address of the VM.

   I run docker with -h option as follows: *docker -h 104.10.x.x *....storm
nimbus

  With the above setting, I'm able to perform operations remotely using
storm ( eg storm list). However, I'm unable to connect to storm UI using
browser. The browser spins forever trying to get cluster information.

Following configuration allows me to connect using the UI but not storm jar.

storm.yaml:
                  storm.zookeeper.servers:
                      - 172.x.x.x.
                  nimbus.seeds: ["1*27.0.0.1*"]

Nimbus seeds point to 127.0.0.1.
And, I *don't run docker with the -h option*.

I tried specifying storm.local.hostname etc. But, I'm not able to get Storm
1.0 work in container.

I lost almost 4 days trying different configuration. Can someone help me?,
please.

Thanks,
Sudha

Mime
View raw message