storm-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Cody Lee <cody...@wellaware.us>
Subject Re: problem in running topology in local mode
Date Sun, 29 Jan 2017 01:50:52 GMT
The answer is likely right in front of you. Maybe take a refresher on dependency scope: https://maven.apache.org/guides/introduction/introduction-to-dependency-mechanism.html


From: sam mohel <sammohel5@gmail.com>
Reply-To: "user@storm.apache.org" <user@storm.apache.org>
Date: Saturday, January 28, 2017 at 10:52 AM
To: "user@storm.apache.org" <user@storm.apache.org>
Subject: Re: problem in running topology in local mode

can someone help , please ?

On Sat, Jan 28, 2017 at 8:11 AM, sam mohel <sammohel5@gmail.com<mailto:sammohel5@gmail.com>>
wrote:
i forgot to mention that iam using jdk 1.6

On Sat, Jan 28, 2017 at 8:09 AM, sam mohel <sammohel5@gmail.com<mailto:sammohel5@gmail.com>>
wrote:
thanks for replying . i searched or how to know the appropratie versions i should write it
but couldn't find . I'm using apache-storm-0.9.6 and when i ran this command mvn dependency:list
i got
org.slf4j:log4j-over-slf4j:jar:1.6.6:provided
org.slf4j:slf4j-api:jar:1.7.5:provided
if you please ,what should i do ? Thanks in advance

On Sat, Jan 28, 2017 at 3:04 AM, Ambud Sharma <asharma525xi@gmail.com<mailto:asharma525xi@gmail.com>>
wrote:
Your dependencies need to be overridden. If you are using Maven please look at your dependency
hierarchy and check what all is using slf log4j and fix it the version of storm you are using.


On Jan 25, 2017 3:35 AM, "sam mohel" <sammohel5@gmail.com<mailto:sammohel5@gmail.com>>
wrote:
is there any help , please ?

On Tue, Jan 24, 2017 at 8:53 AM, sam mohel <sammohel5@gmail.com<mailto:sammohel5@gmail.com>>
wrote:
I got this error when i ran my topology in local mode
clojure.tools.logging$eval1$fn__7 invoke
SEVERE:
java.lang.NoSuchMethodError: org.slf4j.spi.LocationAwareLogger.log(Lorg/slf4j/Marker;Ljava/lang/String;ILjava/lang/String;[Ljava/lang/Object;Ljava/lang/Throwable;)V
    at org.apache.log4j.Category.differentiatedLog(Category.java:186)
    at org.apache.log4j.Category.info<http://org.apache.log4j.Category.info>(Category.java:229)
    at backtype.storm.utils.ShellProcess.getSerializer(ShellProcess.java:78)
    at backtype.storm.utils.ShellProcess.launch(ShellProcess.java:58)
    at backtype.storm.task.ShellBolt.prepare(ShellBolt.java:117)
    at backtype.storm.daemon.executor$fn__3439$fn__3451.invoke(executor.clj:699)
    at backtype.storm.util$async_loop$fn__460.invoke(util.clj:461)
    at clojure.lang.AFn.run(AFn.java:24)
    at java.lang.Thread.run(Thread.java:701)





Mime
View raw message