storm-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Igor Kuzmenko <f1she...@gmail.com>
Subject Re: Kafka spout stops emmiting messages
Date Tue, 24 Jan 2017 09:57:01 GMT
Thanks for reply, Josh.
My maxUncommitedOffset was 250, increasing uncommited offset helped me, but
I still don't understand why spout completly stoped emiting tuples. You
said, that eventualy spout will produce new tuples, after old one will be
acked, but in my case didn't.




On Tue, Jan 24, 2017 at 4:24 AM, fanxinpu@travelsky.com <
fanxinpu@travelsky.com> wrote:

> Hi, Kuzmenkoļ¼š
>
> please pay attention to the number about setMaxUncommittedOffsets, if this
> number is too small, the spout may stop  emitting until the pending tuple
> is acked by the down bolt. You can change the number to a large number.
>
> ------------------------------
> Josh
>
> *From:* Igor Kuzmenko <f1sherox@gmail.com>
> *Date:* 2017-01-24 02:28
> *To:* user <user@storm.apache.org>
> *Subject:* Kafka spout stops emmiting messages
> Hello, I'm trying to upgrade my topology from old kafka spout
> <https://github.com/apache/storm/tree/v1.0.1/external/storm-kafka> (storm-
> kafka project) to new one
> <https://github.com/apache/storm/tree/v1.0.1/external/storm-kafka-client>
> (storm-kafka-client) version 1.0.1. I've configured new spout to work
> with my topology. After deploy it processes and acks few hundreds of
> tuples and then stops. Kafka topic definitely have new messages, and in
> storm UI I can see  kafka spout lag increasing. What could be the problem?
>
>

Mime
View raw message