storm-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Igor Kuzmenko <f1she...@gmail.com>
Subject Re: Kafka monitor unable to get offset lag
Date Wed, 01 Feb 2017 09:01:54 GMT
Yes, topology process data and works fine.
I couldn't find any exceptions in storm logs.   access-web-ui.log contains
only these lines

2017-02-01 11:58:17.315 o.a.s.l.f.AccessLoggingFilter [INFO] Access from:
10.35.63.14 url: http://master001.s:8744/api/v1/cluster/summary principal:
2017-02-01 11:58:17.315 o.a.s.l.f.AccessLoggingFilter [INFO] Access from:
10.35.63.14 url: http://master001.s:8744/api/v1/nimbus/summary principal:
2017-02-01 11:58:25.346 o.a.s.l.f.AccessLoggingFilter [INFO] Access from:
10.35.63.14 url: http://master001.s:8744/api/v1/topology/summary principal:
2017-02-01 11:58:25.346 o.a.s.l.f.AccessLoggingFilter [INFO] Access from:
10.35.63.14 url: http://master001.s:8744/api/v1/cluster/summary principal:
2017-02-01 11:58:25.346 o.a.s.l.f.AccessLoggingFilter [INFO] Access from:
10.35.63.14 url: http://master001.s:8744/api/v1/nimbus/summary principal:

On Tue, Jan 31, 2017 at 5:19 PM, Priyank Shah <pshah@hortonworks.com> wrote:

> Hi Igor,
>
> When you say topology is working fine do you mean you see data flowing?
> Can you try to look up the logs for ui server and paste relevant lines here
> if any?
>
> Priyank
>
> Sent from my iPhone
>
> On Jan 31, 2017, at 4:34 AM, Igor Kuzmenko <f1sherox@gmail.com> wrote:
>
> I've launched topology with new kafka spout. Topology by it self working
> fine, but looking at storm UI I see kafka-monitor exception:
> *Unable to get offset lags for kafka. Reason:
> org.apache.kafka.shaded.common.errors.TimeoutException: Timeout expired
> while fetching topic metadata*
>
> Maybe I forgot to configure something, but then how topology reads
> messages?
>
>

Mime
View raw message