storm-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Sitakant Mishra <sitakanta.mis...@gmail.com>
Subject Regarding Issue with Multi-Lang in Storm While Running Python (WordCountTopology)
Date Mon, 07 Aug 2017 17:02:32 GMT
Hi,

I am trying to run the *WordCountTopology* in storm local mode before
running my own application and I am unable to run it. I am continuously
getting the following error. I have verified that the splitsentence.py file
is kept at the "*multilang/resources"* directory which is in the "
*examples/storm-starter"* directory.

*5729 [Thread-22-split-executor[7 7]] ERROR o.a.s.util - Async loop died!*
*java.lang.RuntimeException: org.apache.storm.multilang.NoOutputException:
Pipe to subprocess seems to be broken! No output read.*
*Serializer Exception:*
*python: can't open file 'splitsentence.py': [Errno 2] No such file or
directory*

*        at
org.apache.storm.utils.ShellProcess.launch(ShellProcess.java:91)
~[storm-core-1.0.3.jar:1.0.3]*
*        at org.apache.storm.task.ShellBolt.prepare(ShellBolt.java:131)
~[storm-core-1.0.3.jar:1.0.3]*
*        at
org.apache.storm.daemon.executor$fn__4973$fn__4986.invoke(executor.clj:791)
~[storm-core-1.0.3.jar:1.0.3]*
*        at org.apache.storm.util$async_loop$fn__557.invoke(util.clj:482)
[storm-core-1.0.3.jar:1.0.3]*
*        at clojure.lang.AFn.run(AFn.java:22) [clojure-1.7.0.jar:?]*
*        at java.lang.Thread.run(Thread.java:745) [?:1.8.0_51]*
*5734 [Thread-30-spout-executor[9 9]] INFO  o.a.s.d.executor - Opening
spout spout:(9)*
*5734 [Thread-28-split-executor[6 6]] ERROR o.a.s.util - Async loop died!*

I have followed the instructions during installation and built my package
successfully with maven. My storm version is 1.0.3 and my python version is
2.7.13. I ran the *ExclamationTopology* and some of my own code which does
not need multi-language support and it works like a charm.

I tried putting file in different locations and changing the relative path,
but still it is not working. I am not able to understand why the multi-lang
support in storm is not working. Any help with this is greatly appreciated.



Thanks and Regards,
Sitakanta Mishra

Mime
View raw message