storm-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Stephen Powis <spo...@salesforce.com>
Subject Difficulties getting log viewer to work in 1.1.1
Date Mon, 25 Sep 2017 08:03:38 GMT
Hey!  I've been struggling getting logviewer to work in storm 1.1.1 and was
wondering if anyone could lend a hand w/ the required configuration and
help me understand where I've gone wrong.

First of all I have the logviewer daemon running on every supervisor host.

Second I've modified the worker.xml A1 appender as follows:

<appenders>
>     <RollingFile name="A1"
>
> fileName="/static/path/log/storm/topologies/${sys:logfile.prefix}-${sys:worker.port}.log"
>
> filePattern="/static/path/log/storm/topologies/archived/${sys:logfile.prefix}-${sys:worker.port}.%i.gz">
>         <PatternLayout>
>             <pattern>${pattern}</pattern>
>         </PatternLayout>
>         <Policies>
>             <SizeBasedTriggeringPolicy size="250 MB"/> <!-- Or every 250
> MB -->
>         </Policies>
>         <DefaultRolloverStrategy max="9"/>
>     </RollingFile>.....
>

Deployed with each topology I have:
topology.worker.childopts  "-Dlogfile.prefix=topology-name-here"

It seems as tho logviewer / storm UI is unable to locate my log files.  I'm
guessing this because of how I have the log appender setup?  Is it possible
to have log viewer locate my log files w/o reverting to the standard
logging path?  Am I missing some configuration option somewhere?

Using the standard log layout of:
"${sys:workers.artifacts}/${sys:storm.id}/${sys:worker.port}/${sys:
logfile.name}" is difficult for us because of how we aggregate our logs and
ensuring that old logs from previous deploys are cleaned up appropriately.

Thanks!
Stephen

Mime
View raw message