storm-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Stig Rohde Døssing <s...@apache.org>
Subject Re: Cannot build storm locally kafka-avro-serializer not found
Date Thu, 21 Sep 2017 16:37:10 GMT
It looks like there's something wrong with your Maven or Nexus setup. When
I build it pulls kafka-avro-serializer from
http://packages.confluent.io/maven/io/confluent/kafka-avro-serializer/1.0/kafka-avro-serializer-1.0.jar.
If you're using Nexus make sure it allows pulling jars from
http://packages.confluent.io. You might also check your .m2/settings.xml to
see if there's anything weird going on. If nothing else you might be able
to temporarily bypass the Nexus server.

2017-09-20 23:10 GMT+02:00 Yi, Dan <dyi@rosettastone.com>:

> Hi,
>
> I tried clean checkout storm project using git and ran the following
> commands, neither of them worked:
>
> mvn clean install -DskipTests
>
> mvn clean install -DskipTests -U
>
> mvn clean install -DskipTests -o
>
> it always ended up with the same error:
>
> Failed to execute goal on project storm-hdfs: Could not resolve
> dependencies for project org.apache.storm:storm-hdfs:jar:2.0.0-SNAPSHOT:
> Failure to find io.confluent:kafka-avro-serializer:jar:1.0 in
> https://xxx/repository/maven-public/ was cached in the local repository,
> resolution will not be reattempted until the update interval of nexus has
> elapsed or updates are forced -> [Help 1]
>  I also tried to git clone Kafaka project itself :
> https://github.com/apache/kafka/
> and build it locally, still cannot build storm due to the same reason, can
> anyone tell me how to work around it?
>
>
>

Mime
View raw message