stratos-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "byt3b0n3 (JIRA)" <j...@apache.org>
Subject [jira] [Updated] (STRATOS-1643) Docker Build of Stratos fails
Date Sat, 12 Dec 2015 22:05:46 GMT

     [ https://issues.apache.org/jira/browse/STRATOS-1643?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

byt3b0n3 updated STRATOS-1643:
------------------------------
    Description: 
I have a Kubernetes Setup with CoreOS and OpenStack.
If I try to build Docker Images all are fine except Stratos which produce following error:

{code:title=core@master ~/apache-stratos-4.1.5-source-release/tools/docker-images/stratos-docker-images/stratos
$ ./docker-build.sh|borderStyle=solid}
...
Step 3 : ADD /files/stratos-installer/config/all/repository/conf/activemq/jndi.properties
/opt/apache-stratos/repository/conf/
INFO[0011] files/stratos-installer/config/all/repository/conf/activemq/jndi.properties: no
such file or directory 
{code}

My Kubernetes Setup is made by just using the original cloud-configs https://github.com/kubernetes/kubernetes/tree/master/docs/getting-started-guides/coreos/cloud-configs

I have one master & 2 nodes

{code:title=fleetctl|borderStyle=solid}
$ fleetctl list-machines
MACHINE		IP		METADATA
6ac63d63...	10.1.1.33	role=master
ce63b120...	10.1.1.37	role=node
ea7db096...	10.1.1.39	role=node
{code}

Kubernetes API test from stratos works.

{code:title=Kubernetes API Example|borderStyle=solid}
{
  "kind": "ServiceList",
  "apiVersion": "v1",
  "metadata": {
    "selfLink": "/api/v1/services",
    "resourceVersion": "105348"
  },
  "items": [
    {
      "metadata": {
        "name": "kubernetes",
        "namespace": "default",
        "selfLink": "/api/v1/namespaces/default/services/kubernetes",
        "uid": "5bc226d8-a086-11e5-9527-fa163e8417c8",
        "resourceVersion": "10",
        "creationTimestamp": "2015-12-12T04:11:03Z",
        "labels": {
          "component": "apiserver",
          "provider": "kubernetes"
        }
      },
      "spec": {
        "ports": [
          {
            "protocol": "TCP",
            "port": 443,
            "targetPort": 443
          }
        ],
        "clusterIP": "10.100.0.1",
        "type": "ClusterIP",
        "sessionAffinity": "None"
      },
      "status": {
        "loadBalancer": {}
      }
    }
  ]
}
{code}

I have only the OpenStack API or Horizon UI available.
Could someone help with this? And please update the documentation especially with more simple
and clear steps. (especially kubernetes)

I'm also available in Slack (#kubernetes-users)

  was:
I have a Kubernetes Setup with CoreOS and OpenStack.
If I try to build Docker Images all are fine except Stratos which produce following error:

{code:title=core@master ~/apache-stratos-4.1.5-source-release/tools/docker-images/stratos-docker-images/stratos
$ ./docker-build.sh|borderStyle=solid}
...
Step 3 : ADD /files/stratos-installer/config/all/repository/conf/activemq/jndi.properties
/opt/apache-stratos/repository/conf/
INFO[0011] files/stratos-installer/config/all/repository/conf/activemq/jndi.properties: no
such file or directory 
{code}

My Kubernetes Setup is made by just using the original cloud-configs https://github.com/kubernetes/kubernetes/tree/master/docs/getting-started-guides/coreos/cloud-configs

I have one master & 2 nodes

{code:title=fleetctl|borderStyle=solid}
$ fleetctl list-machines
MACHINE		IP		METADATA
6ac63d63...	10.1.1.33	role=master
ce63b120...	10.1.1.37	role=node
ea7db096...	10.1.1.39	role=node
{code}

Kubernetes API test from stratos works.

{code:title=Kubernetes API Example|borderStyle=solid}
{
  "kind": "ServiceList",
  "apiVersion": "v1",
  "metadata": {
    "selfLink": "/api/v1/services",
    "resourceVersion": "105348"
  },
  "items": [
    {
      "metadata": {
        "name": "kubernetes",
        "namespace": "default",
        "selfLink": "/api/v1/namespaces/default/services/kubernetes",
        "uid": "5bc226d8-a086-11e5-9527-fa163e8417c8",
        "resourceVersion": "10",
        "creationTimestamp": "2015-12-12T04:11:03Z",
        "labels": {
          "component": "apiserver",
          "provider": "kubernetes"
        }
      },
      "spec": {
        "ports": [
          {
            "protocol": "TCP",
            "port": 443,
            "targetPort": 443
          }
        ],
        "clusterIP": "10.100.0.1",
        "type": "ClusterIP",
        "sessionAffinity": "None"
      },
      "status": {
        "loadBalancer": {}
      }
    }
  ]
}
{code}

I have only the OpenStack API or Horizon UI available.
Could someone help with this? And please update the documentation especially with more simple
and clear steps. (especially kubernetes)

I'm also available Slack (#kubernetes-users)


> Docker Build of Stratos fails
> -----------------------------
>
>                 Key: STRATOS-1643
>                 URL: https://issues.apache.org/jira/browse/STRATOS-1643
>             Project: Stratos
>          Issue Type: Bug
>    Affects Versions: 4.1.5
>            Reporter: byt3b0n3
>              Labels: coreos, docker, install, kubernetes, newbie, openstack
>
> I have a Kubernetes Setup with CoreOS and OpenStack.
> If I try to build Docker Images all are fine except Stratos which produce following error:
> {code:title=core@master ~/apache-stratos-4.1.5-source-release/tools/docker-images/stratos-docker-images/stratos
$ ./docker-build.sh|borderStyle=solid}
> ...
> Step 3 : ADD /files/stratos-installer/config/all/repository/conf/activemq/jndi.properties
/opt/apache-stratos/repository/conf/
> INFO[0011] files/stratos-installer/config/all/repository/conf/activemq/jndi.properties:
no such file or directory 
> {code}
> My Kubernetes Setup is made by just using the original cloud-configs https://github.com/kubernetes/kubernetes/tree/master/docs/getting-started-guides/coreos/cloud-configs
> I have one master & 2 nodes
> {code:title=fleetctl|borderStyle=solid}
> $ fleetctl list-machines
> MACHINE		IP		METADATA
> 6ac63d63...	10.1.1.33	role=master
> ce63b120...	10.1.1.37	role=node
> ea7db096...	10.1.1.39	role=node
> {code}
> Kubernetes API test from stratos works.
> {code:title=Kubernetes API Example|borderStyle=solid}
> {
>   "kind": "ServiceList",
>   "apiVersion": "v1",
>   "metadata": {
>     "selfLink": "/api/v1/services",
>     "resourceVersion": "105348"
>   },
>   "items": [
>     {
>       "metadata": {
>         "name": "kubernetes",
>         "namespace": "default",
>         "selfLink": "/api/v1/namespaces/default/services/kubernetes",
>         "uid": "5bc226d8-a086-11e5-9527-fa163e8417c8",
>         "resourceVersion": "10",
>         "creationTimestamp": "2015-12-12T04:11:03Z",
>         "labels": {
>           "component": "apiserver",
>           "provider": "kubernetes"
>         }
>       },
>       "spec": {
>         "ports": [
>           {
>             "protocol": "TCP",
>             "port": 443,
>             "targetPort": 443
>           }
>         ],
>         "clusterIP": "10.100.0.1",
>         "type": "ClusterIP",
>         "sessionAffinity": "None"
>       },
>       "status": {
>         "loadBalancer": {}
>       }
>     }
>   ]
> }
> {code}
> I have only the OpenStack API or Horizon UI available.
> Could someone help with this? And please update the documentation especially with more
simple and clear steps. (especially kubernetes)
> I'm also available in Slack (#kubernetes-users)



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message