struts-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "spencer p (JIRA)" <j...@apache.org>
Subject [jira] Commented: (WW-1857) Form tags do not render, others do.
Date Tue, 27 Mar 2007 15:00:59 GMT

    [ https://issues.apache.org/struts/browse/WW-1857?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel#action_40696
] 

spencer p commented on WW-1857:
-------------------------------

Sure.  

If I create a page:

---
<%@ taglib prefix="s" uri="/struts-tags"%>
<body>
<s:property value="mySet" />
<s:form namespace="/mySpace" action="a.action"
	method="post">
	<input type="hidden" value="hi"/>
	<s:select name="stuff" list="mySet" />
	<s:submit value="%{'Submit'}" />
</s:form>
</body>
---

It renders as

--
<body>
[test.Item@61, test.Item@62, test.Item@63]
<input type="hidden" value="hi"/>
</body>
---

If I reduce the form tags to <s:form></s:form>.  I still see nothing.  


</body>

> Form tags do not render, others do.
> -----------------------------------
>
>                 Key: WW-1857
>                 URL: https://issues.apache.org/struts/browse/WW-1857
>             Project: Struts 2
>          Issue Type: Bug
>         Environment: tomcat 5.5, java 1.5, jsp 2.4
>            Reporter: spencer p
>
> Using the s:property tag on an attribute works.  ala <s:property name="bob"/>
> Using a form tag, ala <s:form></s:form> does not  <s:submit value="%{'a'}"/>
 does not work as well.

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message