struts-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Philip Luppens (JIRA)" <j...@apache.org>
Subject [jira] Commented: (WW-1918) Select options doesnt render chinese and korean languages correctly
Date Mon, 14 May 2007 10:35:42 GMT

    [ https://issues.apache.org/struts/browse/WW-1918?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel#action_40980
] 

Philip Luppens commented on WW-1918:
------------------------------------

First of all, please do not use the bug tracker to ask for help nor confirmation if an issue
is a bug. Use the user mailing list for this.

By all means, it looks like an IE issue (since they're showing up correctly in the other browsers).
Can you verify that other parts of rendered page suffer from the same problem ? If not, it
might be a select box issue (although I doubt that).

> Select options doesnt render chinese and korean languages correctly
> -------------------------------------------------------------------
>
>                 Key: WW-1918
>                 URL: https://issues.apache.org/struts/browse/WW-1918
>             Project: Struts 2
>          Issue Type: Bug
>    Affects Versions: 2.0.7
>            Reporter: srinivas chinthalapudi
>
> We are currently using struts 2, freemarker, ognl to buid our site. We have a language
selection drop down to select the locale of the user. All other languages display correctly
in the select options except korean and chinese. We see square boxes instead. This happens
only in IE7 and other browser versions render perfectly.
>    I am really not sure whether this is a bug with struts 2 or IE. But I just wanted
to get confirmed this is not the issue with struts.
> ftl entry
> <@s.select name="request_locale" onchange="this.form.submit();"
>               		value="(#session['webwork_locale'] == null) ? ((locale == null) ? 'en'
: locale.toString()) : #session['webwork_locale'].toString()" 
>               		list=r'#{ "en":"English", "ar":"العربية", "de":"Deutsch", 
>               			"es":"español", "fr":"Français", "it":"Italiano", "ko":"한국어",
"lt":"lietuvių", 
>               			"pt":"português", "ro":"Română", "ru":"Русский", "uk":"Українська",
"zh":"中文" }' />
> all the properties file has utf 8 encoding which is correct.
> thanks
> Sri

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message