struts-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Svetlana Reznikov (JIRA)" <j...@apache.org>
Subject [jira] Commented: (WW-1933) HTTP Status 404 - result 'null' not found
Date Thu, 31 May 2007 13:45:58 GMT

    [ https://issues.apache.org/struts/browse/WW-1933?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel#action_41140
] 

Svetlana Reznikov commented on WW-1933:
---------------------------------------

ok, the problem has been solved. It was Sun App Server policy problem.
I added the following permission to the server.policy file and it solved the problem.

permission java.security.AllPermission "createClassLoader";



> HTTP Status 404 - result 'null' not found
> -----------------------------------------
>
>                 Key: WW-1933
>                 URL: https://issues.apache.org/struts/browse/WW-1933
>             Project: Struts 2
>          Issue Type: Bug
>    Affects Versions: 2.0.6
>         Environment: Sun Solaris, Sun App Server 8.1
>            Reporter: Svetlana Reznikov
>            Priority: Critical
>             Fix For: 2.0.9
>
>
> I am sure this issue is not new, and it must be a work around, but unfortunately I was
not able to find it yet.
> We have a local Windows environment (Sun App Server 8.2) where our project works just
fine. But once we deployed it on our server (Sun Solaris) we've got the following error on
every action we have in struts configuration xml. 
> +++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++
> HTTP Status 404 - result 'null' not found
> type Status report
> message result 'null' not found
> description The requested resource (result 'null' not found) is not available.
> --------------------------------------------------------------------------------
> Sun-Java-System/Application-Server
> ++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++
> After some checks of configurations on both servers (no major differences) and included
jars I replaced our project with one from the struts tutorial HelloWorld. < http://struts.apache.org/2.0.6/docs/hello-world.html
>
> This project built in our environment had the same behavior as our oroginal project 
- worked locally and got the "404 error" on Solaris. 
> It must be some parsing of struts config file issue. Struts can "read" the action class,
the method specified executes (checked in logs), but the result page is not read (recognized)
(???)
> I think it's a major problem and hope that the solution can be found. 

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message