struts-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "olivier dupuy (JIRA)" <j...@apache.org>
Subject [jira] Updated: (WW-2026) bug in the portlet demo (missing processFormExampleForward.action file)
Date Wed, 04 Jul 2007 23:35:28 GMT

     [ https://issues.apache.org/struts/browse/WW-2026?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

olivier dupuy updated WW-2026:
------------------------------

    Attachment: Olivier Dupuy.vcf

Hi,

To remind you, my environment is Tomcat 5.5.23 + pluto 1.1 portlet
libraries.
If you have a pointer to the right configuration and/or URL to use for a
portlet, feel free...

I fixed it by a redirect, see the 2 lines to change to make a redirect
but somehow the parameters are not passed properly for the second
request
So I am confused as the example sells a "forward"... So this must not be
the right solution


Maybe your action mapper environment is different from the one shipped
in this demo

Replace in Struts.xml

		...
 		<action name="processFormExampleEdit"
	
class="org.apache.struts2.portlet.example.FormExample">
			<result name="input">
				/WEB-INF/edit/formExampleInput.jsp
			</result>
			<result name="success">
	
/edit/processFormExampleForward.action?firstName=${firstName}&amp;lastNa
me=${lastName}
			</result>
		</action>
		...

by

		...
		<action name="processFormExampleEdit"
	
class="org.apache.struts2.portlet.example.FormExample">
			<result name="input">
				/WEB-INF/edit/formExampleInput.jsp
			</result>
			<result name="success" type="redirect-action">
<<<<<<<<<< 
	
processFormExampleForward.action?firstName=${firstName}&amp;lastName=${l
astName} <<<<<<<<<<<<
			</result>
		</action>
		...

Thanks / Merci
Olivier DUPUY



> bug in the portlet demo (missing processFormExampleForward.action file)
> -----------------------------------------------------------------------
>
>                 Key: WW-2026
>                 URL: https://issues.apache.org/struts/browse/WW-2026
>             Project: Struts 2
>          Issue Type: Bug
>          Components: Examples
>    Affects Versions: 2.0.8
>         Environment: Tomcat 5.5.23 on W2K with the pluto 1.1 portlet support
>            Reporter: olivier dupuy
>         Attachments: Olivier Dupuy.vcf
>
>
> Hi,
> I was just playing with http://localhost:8080/StrutsPortlet/edit/dummy/test/index.action
> tried the <form test> link, entered data and submitted with the following error

> >>>>The requested resource (/StrutsPortlet/edit/processFormExampleForward.action)
is not available
> on the page http://localhost:8080/StrutsPortlet/edit/dummy/test/processFormExampleEdit.action
> Web.xml contains this but this processFormExampleForward.action is missing as a file
> 	<action name="processFormExampleEdit"
> 			class="org.apache.struts2.portlet.example.FormExample">
> 			<result name="input">
> 				/WEB-INF/edit/formExampleInput.jsp
> 			</result>
> 			<result name="success">
> 				/edit/processFormExampleForward.action?firstName=${firstName}&amp;lastName=${lastName}
> 			</result>
> 		</action>

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message