struts-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Don Brown (JIRA)" <j...@apache.org>
Subject [jira] Updated: (WW-1805) Apply "convention over configuration" principles to default interceptor and result name
Date Fri, 02 May 2008 05:57:05 GMT

     [ https://issues.apache.org/struts/browse/WW-1805?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Don Brown updated WW-1805:
--------------------------

    Fix Version/s:     (was: 2.1.3)
                   Future

> Apply "convention over configuration" principles to default interceptor and result name
> ---------------------------------------------------------------------------------------
>
>                 Key: WW-1805
>                 URL: https://issues.apache.org/struts/browse/WW-1805
>             Project: Struts 2
>          Issue Type: Improvement
>            Reporter: Ted Husted
>             Fix For: Future
>
>
> In WW-1707, we offered a consistent set of "camelCase" names for the interceptors and
results. 
> In almost all cases, the interceptor/result name matches the Java class name. 
> Rather than introduce arbitrary exceptions, we should rename either the elements or Java
classes, so that there is a 1:1 "convention over configuration" correspondence. As a pattern,
we could drop the "Servlet" or "Struts" prefix and "Result" or "Interceptor" suffix, or move
the classes to a Result or Interceptor package
> The elements or classes that would need to be renamed are 
> * chain / ActionChainResult
> * externalRef / ExternalReferencesInterceptor
> * execAndWait / ExecuteAndWaitInterceptor
> * exception / ExceptionMappingInterceptor
> * params / ParametersInterceptor
> * staticParams / StaticParametersInterceptor
> * sessionAutowiring / SessionContextAutowiringInterceptor
> * tokenSession /. TokenSessionStoreInterceptor
> * workflow / DefaultWorkflowInterceptor
> * store / MessageStoreInterceptor
> * profiling / ProfilingActivationInterceptor
> Of course, the prior names can be supported on an interim basis to ease migration. 

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message