struts-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Shashank (JIRA)" <j...@apache.org>
Subject [jira] Created: (WW-2980) Client side form validations not working in portlets
Date Tue, 03 Feb 2009 07:06:45 GMT
Client side form validations not working in portlets
----------------------------------------------------

                 Key: WW-2980
                 URL: https://issues.apache.org/struts/browse/WW-2980
             Project: Struts 2
          Issue Type: Bug
          Components: Plugin - Portlet
    Affects Versions: 2.1.6, 2.0.14
         Environment: Websphere Portal Server Express 6.1 and Liferay 5.1.2, JDK 1.5 (06),
Windows
            Reporter: Shashank
            Priority: Critical


Hi, 
I am quite frustrated to see that client side form-validations are not working within portlets.
To illustrate, I have implemented the validations through annotations. 
And on form i have used validate="true" which should produce client side validation javascript.
But it happens so, that only the below line of code is generated:
<script type="text/javascript" src="/<Project Name>/struts/css_xhtml/validation.js"></script>

also in form onsubmit="return validateForm_<form name>();" is generated but this function
[validateForm_<form name>()] is nowhere else 
generated which should be ideally generated after end of form tag.

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message