struts-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Henri Yandell (JIRA)" <j...@apache.org>
Subject [jira] Updated: (STR-3023) Core doesn't compile against Servlet 2.4/JSP 2.0 spec
Date Sat, 07 Mar 2009 07:54:02 GMT

     [ https://issues.apache.org/struts/browse/STR-3023?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Henri Yandell updated STR-3023:
-------------------------------

    Comment: was deleted

(was: Making sure JIRA is rw after upgrade.)

> Core doesn't compile against Servlet 2.4/JSP 2.0 spec
> -----------------------------------------------------
>
>                 Key: STR-3023
>                 URL: https://issues.apache.org/struts/browse/STR-3023
>             Project: Struts 1
>          Issue Type: Bug
>          Components: Core
>    Affects Versions: 1.3.8
>            Reporter: Henri Yandell
>            Priority: Trivial
>             Fix For: Future
>
>         Attachments: STR-3023.patch
>
>
> Just reporting this, not expecting anything to change.
> There are various missing methods in the Mock classes when compiling against the 2.4/2.0
servlet/jsp spec pair. Unfortunately it's not worth even adding these missing methods as a
couple of them (in PageContext) have return types that were not available until JSP 2.0.

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message