struts-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "S. Farshi (JIRA)" <j...@apache.org>
Subject [jira] Commented: (WW-2642) "Page not found" when a url ending with ".action" is entered
Date Thu, 09 Apr 2009 14:24:06 GMT

    [ https://issues.apache.org/struts/browse/WW-2642?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=45854#action_45854
] 

S. Farshi commented on WW-2642:
-------------------------------

This problem happen to be a websphere issue, The fix (PK76656) will be available in fixpack
23 (6.1.0.23) which approximately be available 3 months or more from now[I guess]. However,
setting the following flag as server custom property on websphere would allow to run struts
2.1.9 on Websphere:

com.ibm.ws.webcontainer.assumefiltersuccessonsecurityerror = true

Please keep in mind that you also need to have the following property set as well

om.ibm.ws.webcontainer.invokeFiltersCompatibility = true

I finally managed to test struts 2.1.6 on WAS 6.1.0.21 [With EJB3 , Web2.0 and Webservice
feature packs] successfully. As a side note, There is still a similar problem for running
struts 2.1.6 on Websphere 7.0.0.3 [Properties of no help], I would see if I can have this
also resovled as well.

> "Page not found" when a url ending with ".action" is entered
> ------------------------------------------------------------
>
>                 Key: WW-2642
>                 URL: https://issues.apache.org/struts/browse/WW-2642
>             Project: Struts 2
>          Issue Type: Bug
>          Components: Core Actions, Example Applications
>    Affects Versions: 2.1.2
>         Environment: Websphere V6.1.0.13 
>            Reporter: S. Farshi
>            Priority: Critical
>             Fix For: Future
>
>
> Looking at bug WW-2266 for struts 2.1.4, I get a similar error message [url not found]
but in a different way. I have deployed blank.war for struts 2.1.2 [with basic form authentication
enabled] under the context root ccol. Whenever I enter:
> https://localhost:9445/ccol/index.html
> the page gets redirected to:
> https://localhost:9445/ccol/example/HelloWorld.action
> I can see the page and from within the same browser, I can type any existing url that
ends with ".action". However, if I open a new browser and then enter:
> https://localhost:9445/ccol/example/HelloWorld.action
> I would get "page not found" error [ I do not even get challenged for my id and pwd by
http login dialog]. I uninstalled the application and then deployed the blank.war for struts
2.0.11[with same security setting enabled] and it works with no problem and I never get the
same error. I have been able to create the error consistently over and over by repeating the
above process. I would like to emphasize that blank.war for struts 2.0.11 works perfectly
fine.  I created server dump for struts 2.1.2 and below is the first few lines of the server
dump:
> [5/8/08 9:23:38:095 EDT] , key = java.io.FileNotFoundException com.ibm.ws.webcontainer.extension.DefaultExtensionProcessor.handleRequest
573
> Exception = java.io.FileNotFoundException
> Source = com.ibm.ws.webcontainer.extension.DefaultExtensionProcessor.handleRequest
> probeid = 573
> Stack Dump = java.io.FileNotFoundException: /example/HelloWorld.action
>   ..............
> I also wanted to say that the Websphere version is 6.1.0.13 (which includes the fix for
filter compatibility) and I have set "com.ibm.ws.webcontainer.invokefilterscompatibility "
in server custom properties to true. On the same server "showcase-2.0.11.1" and sample app
for "struts in action" book also run with no problem all have basic security enabled. The
problem only occure for 2.1.2.
> I would like to mention that when I enter https://localhost:9445/ccol/example/HelloWorld.action,
I do not even get the http login dialog box for authenticatio and I get directly "page not
found" error
> A bit more clarification, The problem with 2.1.2 occurs only when web security is enabled
in web.xml. If I disable security, it works. On the other hands, all the struts sample apps
for 2.011.1 [including show-case app] on the same server have security enabled and they work
fine

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message